Re: [xslt] undefined reference to `xmlXPathContextSetCache'

2007/1/5, Jeroen Ruigrok/asmodai <asmodai in-nomine org>:
-On [20070105 14:25], Nicolas Ecarnot (nicolas ecarnot net) wrote:
>-rw-r--r--   1 root  wheel  5284726 Jan  5 10:35 libxml2.a
>-rwxr-xr-x   1 root  wheel      805 Jan  5 10:35*
>lrwxr-xr-x   1 root  wheel       14 Jan  5 13:52 ->
>-rwxr-xr-x   1 root  wheel  2981560 Jan  5 10:35*
>-rwxr-xr-x   1 root  bin    1112822 Mar  1  2006*
>-rw-r--r--   1 root  wheel      219 Jan  5 10:35

Humour me and add a -> as well please

I tried to add this symlink, but the compilation did not got any better.
Side effect : 'vi' couldn't be launched anymore.
Then I tried to rm this last symlink, and vi was still dead.
I tried to remove also the first symlink but same result.
In between, I ran ldconfig each time, but nothing more.

Some cold tears of sweat were begining to drop from my head to my keyboard, so as if I was under windows, I rebooted my OpenBSD server :o|

And my 'vi' restarted to be working fine.
But no better progress on the libxslt compile...

Nope, try:

nm -D /somefolder/libxslt-1.1.17/libxslt/.libs/ | grep

U xmlModuleClose

is what you probably get, which means that xmlModuleClose() is undefined and
needs to be externally (from the library) resolved.

Indeed, this is what I get.
"Externaly" resolved ? means that this reference has to be found in some other place ?

Nicolas Ecarnot

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]