Re: [xml] libxml2-2.6.18 on freebsd

On Tue, Mar 15, 2005 at 12:29:42PM +0000, Alex Shaw wrote:
Hi, im trying to install libxml2-2.6.18 from the FreeBSD ports, there is a problem with the compile on the 
system i am using. I have tried several versions of libxml2 and they all return the same error, which means 
its probably not an issue involved with libxml, but I cant pin down where the error is coming from, or what 
is causing the problem to occur. I was hoping someone on this list would be able to point me in the 
direction of what is causing this.

The error is:
cc -O -pipe -pedantic -W -Wformat -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat 
-Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings 
-Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls -o 
.libs/xpath1 xpath1.o  -L/usr/local/lib ../../.libs/ -lz -liconv -lm -Wl,--rpath 
../../.libs/ undefined reference to `__signbit'

  paphio:~/XML -> grep __signbit *.c
  paphio:~/XML -> grep __signbit *.c include/libxml/*.h
  paphio:~/XML ->

 Somehow your system or compiler includes are not in synch with your
installed libc, sounds bad, but you're right it doesn't sound like a
libxml2 problem.
 The great thing about those systems where everybody recompiles locally is
that you don't have the same system as your neighbour, this is also its
main drawback, you're on your own to debug the problem...


Daniel Veillard      | Red Hat Desktop team
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]