[xml] libxml2-2.6.18 on freebsd

Hi, im trying to install libxml2-2.6.18 from the FreeBSD ports, there is a problem with the compile on the 
system i am using. I have tried several versions of libxml2 and they all return the same error, which means 
its probably not an issue involved with libxml, but I cant pin down where the error is coming from, or what 
is causing the problem to occur. I was hoping someone on this list would be able to point me in the direction 
of what is causing this.

The error is:
cc -O -pipe -pedantic -W -Wformat -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat 
-Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings 
-Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls -o 
.libs/xpath1 xpath1.o  -L/usr/local/lib ../../.libs/libxml2.so -lz -liconv -lm -Wl,--rpath -Wl,/usr/local/lib
../../.libs/libxml2.so: undefined reference to `__signbit'
gmake[3]: *** [xpath1] Error 1
gmake[3]: Leaving directory `/usr/ports/textproc/libxml2/work/libxml2-2.6.18/doc/examples'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/textproc/libxml2/work/libxml2-2.6.18/doc'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/textproc/libxml2/work/libxml2-2.6.18'
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/textproc/libxml2.

Any help here is greatly appreciated 



Alex Shaw

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]