Re: [xml] libxml2-2.6.18 on freebsd

On Tue, 15 Mar 2005 12:29:42 +0000, Alex Shaw
<alex shaw bulletonline com> wrote:
Hi, im trying to install libxml2-2.6.18 from the FreeBSD ports, there is a problem with the compile on the 
system i am using. I have tried several versions of libxml2 and they all return the same error, which means 
its probably not an issue involved with libxml, but I cant pin down where the error is coming from, or what 
is causing the problem to occur. I was hoping someone on this list would be able to point me in the 
direction of what is causing this.

The error is:
cc -O -pipe -pedantic -W -Wformat -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat 
-Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings 
-Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls -o 
.libs/xpath1 xpath1.o  -L/usr/local/lib ../../.libs/ -lz -liconv -lm -Wl,--rpath 
../../.libs/ undefined reference to `__signbit'
gmake[3]: *** [xpath1] Error 1
gmake[3]: Leaving directory `/usr/ports/textproc/libxml2/work/libxml2-2.6.18/doc/examples'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/textproc/libxml2/work/libxml2-2.6.18/doc'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/textproc/libxml2/work/libxml2-2.6.18'
gmake: *** [all] Error 2
*** Error code 2

I don't really know what your problem might be, and I don't have time
to investigate, but I just wanted to say that I just installed 2.6.18
from ports on my 5.3 laptop. I see in the manpage for signbit that
it's a macro added to the math library starting from version 5.1 of
FreeBSD, are you running 4.x? Maybe it's a glitch and you should
contact the port maintainer? Anyway, I don't think it's for this list.

Best regards,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]