Re: workspace issue with sawfish 1.5.0

On Fri, 24 Jul 2009, Christopher Roy Bratusek wrote:

> On Fri, 24 Jul 2009
> Allin Cottrell <cottrell wfu edu> wrote:
> >
> > Well, it's clearly a gnome issue, since gnome-panel provokes the
> > assertion failure in libwnck.  But it also suggests some sort of
> > backward incompatibility in sawfish and/or rep-gtk, since when
> > these are "downgraded" things work again.  On rep-gtk: to be more
> > precise, the version that I know works for me is in fact 0.18.3.
> ... well the problem is: where haven't major changes to rep-gtk
> before 0.90.0 (git), except the removal of libgnome* bindings (which
> was only used in sawfish-ui - therefore can't be related to this) ...

I will try on my work machine again tomorrow.  Meanwhile I'm
experimenting on my home machine, running Ubuntu 8.04.  I want to
leave this machine automatically managed so far as possible (and
up till now I've been running metacity, though I prefer sawfish),
so I install custom software into /opt.  In this case, that was
librep-0.90.0, rep-gtk-0.18.6r2 and sawfish-1.5.0, into
/opt/sawfish.  I found a couple of small problems.

First, librep.pc is not quite right.  When you invoke it with the
--libs option it does not give the prefix for -lrep:

root myrtle:/usr/src/sawfish# pkg-config --libs librep
-lrep -lcrypt -lgmp -lm

With my installation it should say "-L/opt/sawfish/lib -lrep",
otherwise librep will not be found at compile time, as indeed it
was not when I tried to build sawfish.  The "-L/$prefix" bit can
be dropped if $prefix is a location automatically searched by the
linker, but not otherwise.  I had to hack the sawfish Makefile to
get a complete build.

Second, there's an oddity in unix_processes.c in the librep
sources.  I had to patch as follows to get librep to build using
Ubuntu's gcc 4.2.4 (Ubuntu 4.2.4-1ubuntu4):

root myrtle:/usr/src/sawfish/librep-0.90.0/src# diff \
unix_processes.c.orig unix_processes.c
>     char c = FIRST_PTY_LETTER;

Having done that, I got sawfish running, but here's another
oddity.  I don't know which program or library is at fault here,
but on Ubuntu 8.04 (gnome 2.22.3), sawfish did not show up under
/System/Preferences/Sessions, "Current session" tab.  If I run
metacity it appears; if I remove the "Restart" flag from metacity,
kill it, and start sawfish, sawfish does not appear in the session
listing -- even if I close the Session window and re-open it.

And, yes, I did include

(require 'sawfish.wm.gnome.integration)

in ~/.sawfishrc.

Allin Cottrell

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]