Re: workspace issue with sawfish 1.5.0

On Fri, 24 Jul 2009, Christopher Roy Bratusek wrote:

> On Fri, 24 Jul 2009 16:42:32 -0400 (EDT)
> Allin Cottrell <cottrell wfu edu> wrote:
> > Hello all,
> >
> > I've been a big fan of sawfish for several years. Thanks very
> > much to the developers.
> >
> > Today I tried updating from rep-gtk 0.18 and sawfish to
> > rep-gtk 0.18.6r2 and sawfish 1.5.0.  Everything built OK but
> > when I restarted X sawfish wasn't there and my X error log
> > contained a complaint about gnome-panel:
> >
> > (gnome-panel:PID) Wnck-CRITICAL **: wnck_workspace_get_number:
> > assertion `WNCK_IS_WORKSPACE (space)' failed
> >
> > I was able to restart sawfish manually, but the desktop was messed
> > up, with icons overlapping panels.  I tried deleting my old
> > ~/.sawfish/custom just in case there was anything incompatible in
> > there and started X again.  No dice, same problem.
> >
> > I then tried reverting sawfish to  Again the broken
> > start-up.  Finally I reverted rep-gtk to 0.18 and everything works
> > again.  But I'd like to retry the update if I can figure out
> > what's going wrong.
> >
> > I should perhaps mention that my gnome version is rather old: the
> > panel is gnome-panel-  That's because I feel that recent
> > gnome has been too "dumbed down" -- there are things I can do with
> > the old gnome and that can't with recent releases.  But my gtk
> > installation is current, version 2.16.5.
> >
> Boah. I would like to help you, but it's rather hard to get your
> setup ... did you also update librep? you should, as sawfish 1.5
> requires a pretty new one, but you did not mention it.

Yes, I updated to librep-0.90.0.  That worked fine.

> ... workspace-code did not change for a very long time, I'm pretty sure
> it's GNOME causing the issue, as sawfish works well, standalone, with
> recent GNOME, KDE3 and KDE4.

Well, it's clearly a gnome issue, since gnome-panel provokes the
assertion failure in libwnck.  But it also suggests some sort of
backward incompatibility in sawfish and/or rep-gtk, since when
these are "downgraded" things work again.  On rep-gtk: to be more
precise, the version that I know works for me is in fact 0.18.3.

Allin Cottrell

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]