workspace issue with sawfish 1.5.0

Hello all,

I've been a big fan of sawfish for several years. Thanks very
much to the developers.

Today I tried updating from rep-gtk 0.18 and sawfish to
rep-gtk 0.18.6r2 and sawfish 1.5.0.  Everything built OK but
when I restarted X sawfish wasn't there and my X error log
contained a complaint about gnome-panel:

(gnome-panel:PID) Wnck-CRITICAL **: wnck_workspace_get_number:
assertion `WNCK_IS_WORKSPACE (space)' failed

I was able to restart sawfish manually, but the desktop was messed
up, with icons overlapping panels.  I tried deleting my old
~/.sawfish/custom just in case there was anything incompatible in
there and started X again.  No dice, same problem.

I then tried reverting sawfish to  Again the broken
start-up.  Finally I reverted rep-gtk to 0.18 and everything works
again.  But I'd like to retry the update if I can figure out
what's going wrong.

I should perhaps mention that my gnome version is rather old: the
panel is gnome-panel-  That's because I feel that recent
gnome has been too "dumbed down" -- there are things I can do with
the old gnome and that can't with recent releases.  But my gtk
installation is current, version 2.16.5.

Allin Cottrell
Department of Economics
Wake Forest University

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]