Re: Can't build PyGObject because jhbuild bootstrap fails

Hi Timo,

On Tue, 24 Apr 2012 12:41:02 +0200
Timo Vanwynsberghe <timovwb gmail com> wrote:
> I had the same issue last week on a Ubuntu 11.10 system, it always
> failed on the tar.xz packages. The solution was to get the latest
> jhbuild [1] and use that one instead of the one packaged in Ubuntu.
> Cheers,
> Timo
> [1]

I tried that and jhbuild bootstrap worked:-)

However when I then tried jhbuild build pygobject it wouldn't build some
Gtk-docs-related stuff (so I opted to ignore and continue), but also
failed to build glib, py2cairo, gobject-introspection---and consequently

So in the end, I've been unable to install PyGObject into my local
Python 3.1 and Python 3.2 builds. This is disappointing. I guess I'll
have to wait until Python 3 + PyGObject for Gtk+ 3 is a matter of
installing standard packages on the major Linux distros.

Anyway, thanks to you and the others who tried to help.

Mark Summerfield, Qtrac Ltd,
    C++, Python, Qt, PyQt - training and consultancy
        "Programming in Go" - ISBN 0321774639

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]