Re: [orca-list] Installing Ubuntu mate 20.10 with orca

I downloaded ubuntu-mate 21.04 and tried to get it running in gnome-boxes. This is what I found.

Upon opening up the virtual machine, I pressed the enter key after a couple of seconds. About 20 to 25 seconds later I heard a little tune that let me know that it had started. I had to press the tab key followed by the space bar, then I could press alt+super+s to start orca and then alt+control+d to focus the desktop. From there I could see the install icon and go to its properties. The command to run the installer is

sudo --preserve-env=DBUS_SESSION_BUS_ADDRESS,XDG_RUNTIME_DIR sh -c 'ubiquity gtk_ui'

So I played with that. The obvious thing to try was to add ,GTK_MODULES to the end of that list of environment variables to preserve. The other thing I tried was to run the same thing from inside of a terminal using only sudo -E like so:

sudo -E ubiquity gtk_ui

which should have preserved the whole environment. The last thing I tried was to change the desktop launcher so that its command to run was

sudo -E sh -c 'ubiquity gtk_ui'

In all cases, I still ended up with a non-speaking installer. I'm not sure where the bug is, but as you can see, everything I tried got the same result, just a tune telling me that the installer had started and an inaccessible window in my alt+tab pop-up that says "install, as superuser." At this point, I'm at a loss, as I don't know what will make this installer speak. In both Arch and Fedora, administration applications speak without any issues under MATE, and I don't even seem to need the GTK_MODULES environment variable to be set now. So I can't even say at this point why the Ubuntu installer fails to speak, or how to fix the problem, since I tried all I could think of. If anyone knows of anything else that could work, please feel free to chime in here.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]