Re: [orca-list] orca makes qt5 applications extremely unstable (or maybe at-spi ?)


Thanks for your time and for all the hints you have posted to the list today.

It turned out that I was running Gnome on Wayland and this is a Wayland migration related crash. If I run transmission-qt in Gnome on, it's running with no crashes like I've explained earlier.



On 05.12.2016 at 12:10 Joanmarie Diggs wrote:
Hey Peter.

I just tried this in Fedora 25 using Transmission 2.92 which claims to
be using QT version 5.7.0. No crash here using the steps you provided below.

That said, if a Qt app is crashing as a result of Orca examining
accessible objects in that app, the bug is likely in the app or the
app's toolkit. Are you able to run transmission-qt under gdb? If not, if
you launch transmission-qt from within a terminal, does it provide any
output when the crash occurs?


On 12/01/2016 07:58 AM, Peter Vágner wrote:

I have also noticed QT5 based packages crashing a lot.

Now if I am seeing the discussion in context I am starting to wonder
whether this might have something to do with the recent flat review

I can reproduce a crash with transmission-qt

- Make sure orca is running

- launch transmission-qt

- Once the main window is showing press ctrl+o to bring up the open file

Results: Booom, transmission-qt exits with a segmentation fault.



On 01.12.2016 at 12:29 Alex ARNAUD wrote:
Dear Tyna,

On Debian 8 and Debian 9, both QT 5.3.2 or 5.7.1 and AT-SPI 2.14.0 or
2.22.0 with Orca 3.22 or from GIT we experience segfault on the new
Virtualbox 5.1 based on QT5.

If Orca is disabled the problem doesn't appear even if I have the
screen magnifier (Compiz/EZoom) enabled that tracks AT-SPI events.

Best regards.
orca-list mailing list
orca-list gnome org
Orca wiki:
Orca documentation:
GNOME Universal Access guide:
Log bugs and feature requests at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]