Re: [orca-list] Recording audio from the soundcard




Is there a pulseaudio problem? Reboot and try "pactl list sources".

luciano de souza writes:
After some days of tests, I have partial success.

The first atempt to record sound from my soudcard is that gently explained here.

parec -d 1 > recording.wav

This command should work if I am using Pulse Audio. I don't knew if
it's true, but regarding the fact I got an error, it's more probably I
use Alsa. After the "parec" command, playing the wav with mplayer, I
was informed the format is not recognized and format has not the lirc
support.

So I tried my second atempt:

gst-launch pulsesrc device=1  ! autoaudiosink
gst-launch pulsesrc device=1 ! wavenc ! filesink location=output.wav

Yes, the sound is recorded as I wanted. I concluded the problem is
solved. I made several records and everything is normal. However,
after restart the computer, I think this is the event, but I am not
sure,  the command "gst-launch pulsesrc device=1 ! wavenc ! filesink
location=output.wav" produces a empty audio with the same message of
unknown format and lack of lirc support.

I think: perhaps I have to type the command "gst-launch pulsesrc
device=1  ! autoaudiosink" each time I restart the computer. So I did
it. After pasting the command on the terminal, a strange effect was
produced. Orca starts to read the work "defining" and, after a
fraction of second, a second voice, a third, a forth, a crowd of
voices had been adding, increasing the volume in a crazy choir of
Orcas. The result is that I can't record.

I try:

sudo apt-get purge gstreamer1.0
sudo apt-get install gstreamer1.0

The first atempt failed, producing the choir of Orcas, the second
atempt was successful, but after restarting the machine, the faile
came out again.

Yes, I know is very simple and good to record audio with Gstreamer,
but I don't know  why gst-launch becomes crazy after the computer
restarting. Does someone have any ideia?

Thank you for the big advances I have up to now.

Best regards,




2014/1/11, luciano de souza <luchyanus gmail com>:
Hello all,

I have been trying to record sounds from my soundcard. I got a tip here:
http://jordilin.wordpress.com/2006/07/28/howto-recording-audio-from-the-command-line/
The intention is to capture an audio from Firefox.
By means of arecord, I can record sounds using the commandline.
But I don't know how to win a accessibility problem. Orca does not
behave very well in alsamixer dialog.
Before recording my audio with arecod, I should configure my input
with certain parameters.
I have tried also Audio-Recorder, but the √°udio is always empty.
Does someone have a tip to record sounds from the soundcard using
terminal or a graphical application?
I have certain preference to do it by means of terminal, but any tip is
welcome!

Regards,

--
Luciano de Souza



-- 
Luciano de Souza
_______________________________________________
orca-list mailing list
orca-list gnome org
https://mail.gnome.org/mailman/listinfo/orca-list
Visit http://live.gnome.org/Orca for more information on Orca.
The manual is at http://library.gnome.org/users/gnome-access-guide/nightly/ats-2.html
The FAQ is at http://live.gnome.org/Orca/FrequentlyAskedQuestions
Log bugs and feature requests at http://bugzilla.gnome.org
Find out how to help at http://live.gnome.org/Orca/HowCanIHelp
-- 
Les Smithson


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]