Hi joanie,
On Sunday 09 May 2010 05:59 PM, Joanmarie Diggs wrote:

Over the years, the Orca team had gotten into the habit of dumping
everything, including the kitchen sink, into Much of what
got dumped there had poorly-chosen and/or inconsistent names. For
instance, if you were reading the code and saw that we were calling
getKeybinding(), it would be reasonable for you to conclude that what
the code was doing was getting an Orca keybinding. And you'd be really
wrong: This hypothetical code was getting a list which contained a
mnemonic, accelerator, and shortcut for a widget. That's just one

Ok, this is really good news. I was actually reading some code and this had confused me.

But I thought I might be too stupid to ask on this list because all contributers would find it so basic that it was too obvious to answer.

So.... This refactor should help people who are already developers make
sense of things when reading Orca's code. It should reduce the need for
people to have to hunt down each and every method in order to figure out
what it does. Etc.

Joanie, I had sent you a private mail for asking some specific help on getting started with hacking orca. I have a lot of python experience and i also have sighted colligues who wish to help along.
So if you can reply my email, I can even get started.

Happy hacking.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]