Re: [orca-list] I can not configure uppercase voice in orca preferences page

Hi Will,
I believe to be found the cause, I think that it is related to the translation to brazilian portuguese.

Inspecting the function _getACSSForVoiceType in the file, I found the following code:

        if voiceType == _("Default"):
            voiceACSS = self.defaultVoice
        elif voiceType == _("Uppercase"):
            voiceACSS = self.uppercaseVoice
        elif voiceType == _("Hyperlink"):
            voiceACSS = self.hyperlinkVoice
            voiceACSS = self.defaultVoice
        return voiceACSS

The problem is that the parameter voiceType never contains the value "default" and "uppercase".
The values are translated to portuguese( "padrão" and maiúsculas").
The value "hyperlink" is not translated, so it works correctly.

I don't know how to fix!

On 18-02-2009 05:47, Willie Walker wrote:
Hi Jose:

I wonder if this is specific to IBM ViaVoice or if I've just not run the exact steps to reproduce the problem in the many different ways I've spent testing this. :-(

As an experiment, can you try using a different speech engine, such as eSpeak.


Jose Vilmar Estacio de Souza wrote:
Hi Will,
I tried from svn but it doesn't work.
The problem happens to me everytime, with the .orca directory present or not.

I have a coleague in Brasil with the same problem.

He also uses ibm ViaVoice.

On 17-02-2009 22:28, Willie Walker wrote:
I checked in a new patch to trunk that *hopefully* resolves the issue. It at least resolves the issue I was able to reproduce. Jose - please pull from trunk and test this and let me know if you find any issues.


Willie Walker wrote:
Hi Jose:

I'm getting closer. Are you seeing this only the first time you ever customize Orca (i.e., ~/.orca doesn't exist yet)? What I'm experiencing is that if I run orca with no ~/.orca directory, pressing "OK" or "Apply" in the preferences dialog makes it seem as though my uppercase voice settings where ignored.

But, all times after that (i.e., my ~/.orca directory exists), the settings changes are saved as expected. Is this what you're noticing?


Jose Vilmar Estacio de Souza wrote:
Hi Will,
In attach the debug file and my
One important observation is that I use IBM ViaVoice as my primary synthesizer.

Steps to reproduce:
1. Activate orca's preference dialog and select the speech page.

2. Press tab 4 times and press down key. This may select the uppercase voice configuration.

3. press tab until you find the pitch parameter.

4. Change the value. Orca starts to speak using the new pitch value as expected

5. press the apply button.
Note that orca continuous speaking using the newest pitch value.

6. press tab until you find the default configuration voice.
7. press tab again until you find the pitch parameter.
Note that the value is the same applied in the step 4.

If I try to change the hyperlink configuration voice, it works as expected.

On 17-02-2009 13:17, Willie Walker wrote:
Hi Jose:

I just tested this and it seems to work fine for me. :-( Can you tell me the exact steps you are taking? In addition, can you enable Orca debugging ( and send me the debug file?



Jose Vilmar Estacio de Souza wrote:
Hi all,
After update to revision 4570, orca don't let me configure the uppercase voice in the speech preference page. The problem is that when I select the uppercase voice to be configured, orca shows me the parameters configured to the default voice and the changes are made in the default voice instead of uppercase voice configuration.

I suspect that this related to bug #419123.

Orca-list mailing list
Orca-list gnome org
Visit for more information on Orca

José Vilmar Estácio de Souza
Informal Informatica
msn: vilmar informal com br
aim: zevilmar
gmail: jvilmar gmail com
fone: +55 21-2555-2650
cel: +55 21-8868-0859

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]