Re: Orca has trouble finding dialogs

Aha - bittornado-gui is the package name on Ubuntu.  The thing keeps
asking me for a *.torrent file and then pops up a usage dialog and
crashes when I press Cancel.  I've never really used a bittorrent
before, though, so I might be doing something wrong.
That's also a problem i had, so i went to a web page with a link that
pointed me to a bittorrent file and tried to click on it. I got the
"Open  with" dialog in Firefox and decided to open the file with
Bittornado. After hitting the OK button to get out of the dialog, the
bittornado client came up, but i couldn't access it and so on, because i
had to reach a dialog where it would ask me to save the session
somewhere, and that dialog couldn't be accessed. I couldn't reach the

Very odd.  I don't know what's going on here.  A possibility (though I'm
not even 50% sure) is that Python clients like the btdownloadgui app for
bittornado might not be properly initializing threads or handling the
Python GIL correctly.  As a result, when the AT-SPI support is loaded
and used, it might be causing a deadlock somewhere.  The same thing
might be happening with the freeloader client, which is also a Python

In any case, if I run the btdownloadgui by hand, I notice that it core
dumps.  Seems like a troubled app. agenda wizard, there must be a dialog present because
there pops up a read-only template and there appears to be form fields
which you can fill in, and those must be in a dialog that Orca can't
I'd like to check this out.  How do you bring up the agenda wizard?

1. make sure you have the Java runtime and the java access bridge
2. Go to File|Wizards and from there choose "agenda..." There should pop
up a dialog box where you can change settings for things as participants
in a meeting and so on and so forth, but Orca can't see that dialog,
only the template of the agenda. It doesn't matter if you minimize
windows that could be in the way. Orca doesn't reach that dialog anyway.

Hmmm...very interesting.  This is probably worth filing as a bug.

Should i file it against Orca or

I'd say start with Orca.  We can always move it to OOo if we think the
problem lies there.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]