Re: nmcli c does not list modem device - part 2

On Mon, 2016-11-14 at 16:28 +0200, matti kaasinen wrote:
2016-11-11 19:41 GMT+02:00 Dan Williams <dcbw redhat com>:

This should be handled by usb_modeswitch.  Either it's not getting
correctly from udev, or there's a bug in usb_modeswitch for your
device.  The fact that you can run it manually probably means
udev related, probably the usb_modeswitch udev rules.

I studied this - and did not find proper reason/solution. However, it
clear that usb_modeswitch installation is different between
previous/current distribution versions. It seems that previous had
systemd stuff than current one (for instance systemd unit template).
tried to install that stuff manually, but it did not help. However, I
noticed that switching started working when I started "udevd monitor"
to get debugging information that I did not get before just enabling
logging in usb_modeswitch.conf file. Both logging and switching
after starting udevd. I suppose I should contact to maintainers of
layer installing usb_modeswitch (meta-openembedded).

mmcli -L
does not see any modems before I run that command and naturally
nmcli c
does not see modems, too.

Yeah, that makes sense; it's not switched yet.

Log shows that huawei driver proceeds fine after I run modeswitch
creating ttyUSB terminals. However, when old version produced
(interface type 8) new MM produces generic interface (type 14).
regarding this new interface:
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  (wwan0): 'wwan'
not available; creating generic device
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  (wwan0): new
device (carrier: OFF, driver: 'huawei_cdc_ncm', ifindex: 3)
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  devices added
iface: wwan0)
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  device added
iface: wwan0): no ifupdown configuration found.

What do you get for "cat /sys/class/net/wwan0/uevent"?  Do you see
"DEVTYPE=wwan" in there?

Yes that I can see ( I don't remember now is this patched version or

If not, then the kernel driver should be
fixed to tag this device as a WWAN device, and then NM will ignore
interface and wait for ModemManager to announce the modem.

If you do see DEVTYPE=wwan, can you run NM with debug logging
(--log-level=debug) and see what it reports?

Are you sure you have the NM WWAN plugin installed and recognized
NM?  It'll print out something at startup about it:

Loaded device plugin: NMWwanFactory

I'm pretty sure that it is not installed. In fact, I don't see this
built in the build directory. I tried study, what configuration
options I
needed to get it build, but really, I did not find any regarding
Also, I did not find anything from documentation regarding wwan
Would I need configuration option to get wwan pluging loaded (after
it gets
somehow built)?

NM looks for device plugins in $LIBDIR/NetworkManager/.  If the plugin
exists there NM will try to load it and report an error if it cannot.

The NM build system will attempt to build the WWAN plugin if you either
(a) have ModemManager libraries installed in a pkg-config-accessible
path, or (b) if you pass --with-modem-manager-1 at configure time.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]