nmcli c does not list modem device - part 2

Hi (again)!

I discussed this problem originally in https://mail.gnome.org/archives/networkmanager-list/2016-March/msg00079.html

I had to upgrade my set-up that is currently as follows:
I am using Huawei 3131 modem whose ID should switch from 14fe to 1506
Platform is yocto based am335x board running on Linux 4.4, NM version 1.0.10, MM version 1.4.12. I have tried to patch MM with commit number 359ec84671f9fc0869443b9f0b9555324a0fff78 to fix Huawei AT^NDISDUP problem but in fact I do not see any difference to opera the version without patching.

I changed from dhclient to internal dhcp client in order to get rid of IP address change immediately after boot. That seems working.

Modem mode does not change from Mass Storage/SD Storage to Modem.
However, mode switches quite fine if I run manually command:
usb_modeswitch -I -W -c /usr/share/usb_modeswitch/12d1\:14fe  --default-vendor 12d1 --default-product 14fe --target-product 1506

I don't know, if this is something that modemmanager should bring for udev to make switching or should it come directly from usb_modeswitch set-up. Anyhow, that command uses the usb_modeswitch database.

mmcli -L
does not see any modems before I run that command and naturally
nmcli c
does not see modems, too.

Log shows that huawei driver proceeds fine after I run modeswitch command creating ttyUSB terminals. However, when old version produced modem (interface type 8) new MM produces generic interface (type 14). NM reports regarding this new interface:
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  (wwan0): 'wwan' plugin not available; creating generic device
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  (wwan0): new Generic device (carrier: OFF, driver: 'huawei_cdc_ncm', ifindex: 3)
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  devices added (path: /sys/devices/platform/ocp/47400000.usb/47401c00.usb/musb-hdrc.1.auto/usb2/2-1/2-1:1.1/net/wwan0, iface: wwan0)
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  device added (path: /sys/devices/platform/ocp/47400000.usb/47401c00.usb/musb-hdrc.1.auto/usb2/2-1/2-1:1.1/net/wwan0, iface: wwan0): no ifupdown configuration found.

Can anyone say how to proceed or is more profound debugging needed or any other information?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]