Re: nmcli c does not list modem device - part 2

On Fri, 2016-11-11 at 15:22 +0200, matti kaasinen wrote:
Hi (again)!

I discussed this problem originally in

I had to upgrade my set-up that is currently as follows:
I am using Huawei 3131 modem whose ID should switch from 14fe to 1506
Platform is yocto based am335x board running on Linux 4.4, NM version
1.0.10, MM version 1.4.12. I have tried to patch MM with commit
359ec84671f9fc0869443b9f0b9555324a0fff78 to fix Huawei AT^NDISDUP
but in fact I do not see any difference to opera the version without

I changed from dhclient to internal dhcp client in order to get rid
of IP
address change immediately after boot. That seems working.

Modem mode does not change from Mass Storage/SD Storage to Modem.
However, mode switches quite fine if I run manually command:
usb_modeswitch -I -W -c /usr/share/usb_modeswitch/12d1\:14fe
--default-vendor 12d1 --default-product 14fe --target-product 1506

I don't know, if this is something that modemmanager should bring for
to make switching or should it come directly from usb_modeswitch set-
Anyhow, that command uses the usb_modeswitch database.

This should be handled by usb_modeswitch.  Either it's not getting run
correctly from udev, or there's a bug in usb_modeswitch for your
device.  The fact that you can run it manually probably means something
udev related, probably the usb_modeswitch udev rules.

mmcli -L
does not see any modems before I run that command and naturally
nmcli c
does not see modems, too.

Yeah, that makes sense; it's not switched yet.

Log shows that huawei driver proceeds fine after I run modeswitch
creating ttyUSB terminals. However, when old version produced modem
(interface type 8) new MM produces generic interface (type 14). NM
regarding this new interface:
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  (wwan0): 'wwan'
not available; creating generic device
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  (wwan0): new
device (carrier: OFF, driver: 'huawei_cdc_ncm', ifindex: 3)
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  devices added
iface: wwan0)
Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  device added (path:
iface: wwan0): no ifupdown configuration found.

What do you get for "cat /sys/class/net/wwan0/uevent"?  Do you see
"DEVTYPE=wwan" in there?  If not, then the kernel driver should be
fixed to tag this device as a WWAN device, and then NM will ignore the
interface and wait for ModemManager to announce the modem.

If you do see DEVTYPE=wwan, can you run NM with debug logging enabled
(--log-level=debug) and see what it reports?

Are you sure you have the NM WWAN plugin installed and recognized by
NM?  It'll print out something at startup about it:

Loaded device plugin: NMWwanFactory (/usr/lib64/NetworkManager/libnm-


Can anyone say how to proceed or is more profound debugging needed or
other information?

networkmanager-list mailing list
networkmanager-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]