Re: nmcli c does not list modem device - part 2

2016-11-11 19:41 GMT+02:00 Dan Williams <dcbw redhat com>:
This should be handled by usb_modeswitch.  Either it's not getting run
correctly from udev, or there's a bug in usb_modeswitch for your
device.  The fact that you can run it manually probably means something
udev related, probably the usb_modeswitch udev rules.
I studied this - and did not find proper reason/solution. However, it is clear that usb_modeswitch installation is different between previous/current distribution versions. It seems that previous had more systemd stuff than current one (for instance systemd unit template). I tried to install that stuff manually, but it did not help. However, I noticed that switching started working when I started "udevd monitor" just to get debugging information that I did not get before just enabling logging in usb_modeswitch.conf file. Both logging and switching worked after starting udevd. I suppose I should contact to maintainers of this layer installing usb_modeswitch (meta-openembedded).

> mmcli -L
> does not see any modems before I run that command and naturally
> nmcli c
> does not see modems, too.

Yeah, that makes sense; it's not switched yet.

> Log shows that huawei driver proceeds fine after I run modeswitch
> command
> creating ttyUSB terminals. However, when old version produced modem
> (interface type 8) new MM produces generic interface (type 14). NM
> reports
> regarding this new interface:
> Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  (wwan0): 'wwan'
> plugin
> not available; creating generic device
> Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  (wwan0): new
> Generic
> device (carrier: OFF, driver: 'huawei_cdc_ncm', ifindex: 3)
> Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  devices added
> (path:
> /sys/devices/platform/ocp/47400000.usb/47401c00.usb/musb-
> iface: wwan0)
> Nov 11 12:55:20 cpr3 NetworkManager[483]: <info>  device added (path:
> /sys/devices/platform/ocp/47400000.usb/47401c00.usb/musb-
> iface: wwan0): no ifupdown configuration found.

What do you get for "cat /sys/class/net/wwan0/uevent"?  Do you see
"DEVTYPE=wwan" in there?  
Yes that I can see ( I don't remember now is this patched version or not, though)
If not, then the kernel driver should be
fixed to tag this device as a WWAN device, and then NM will ignore the
interface and wait for ModemManager to announce the modem.

If you do see DEVTYPE=wwan, can you run NM with debug logging enabled
(--log-level=debug) and see what it reports?

Are you sure you have the NM WWAN plugin installed and recognized by
NM?  It'll print out something at startup about it:

Loaded device plugin: NMWwanFactory (/usr/lib64/NetworkManager/libnm-
I'm pretty sure that it is not installed. In fact, I don't see this plugin built in the build directory. I tried study, what configuration options I needed to get it build, but really, I did not find any regarding wwan. Also, I did not find anything from documentation regarding wwan plugin. Would I need configuration option to get wwan pluging loaded (after it gets somehow built)?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]