Re: failure with bridge devices

On Mon, 28 Sep 2015 09:05:02 +0200
Olaf Hering <olaf aepfle de> wrote:

I'm running openSUSE Tumbleweed, with GNOME 3.16.2 and NM 1.0.6, and
have odd issues with networking.

Initially GNOME automatically configured the onboard ethernet and
named it "Wired Connection 1". I added a few VPN connections and all
was fine.

A few weeks later I finally got around to reenable my winxp-tax VM.
For this I needed a bridge. The GNOME UI is appearently unable to
handle bridge. I was unable to get online, under the hood only the
onboard connection was enabled.

Later I found nm-connection-editor. This showed the bridge devices
etc. But in the end, since both seem to disagree about what is
configured, I removed the related config files from
/etc/NetworkManager/system-connections, used nm-connection-editor to
configure a bridge with the onboard ethernet. After a reboot it
finally worked. The GNOME UI is still unable to recognize the  bridge
connection. But in the end I was able to run the VM and all was fine

With todays TW snapshot the IPv4 part of the connection did not get
up. I found the nmcli command. It showed the bridge is online, but no
IPv4 route was set. Dowing down and up showed that only the bridge
came up, but not the onboard device. Trying the GNOME UI did not get
a connection either.

To my surprise, once I ran 'nmcli connection up bridge' the
established onboard connection from GNOME changed something, now the
bridge came up fine including IPv4. Up to now only IPv6 was usable to
get outside.

So my questions:
Are there known bugs in the cooperation between NM and GNOME?
I don't think there is a known serious issue.

Are bridge devices fully supported? If so, why did NM not bringup
onboard before configuring bridge?
Yes, bridge configurations are supported. You might got confused by
the fact bringing up a bridge profile does not automatically bring up
its slaves. Basically, you need to connect all slaves (bridge master
will be connected as a dependency).

But, as you have found there is a new property to influence the
behaviour (connection.autoconnect-slaves). When you set it to '1' you
can activate bridge and its slaves will be activated too.

Does NM rely on the iproute2 package in any way?

NetworkManager does not use iproute2 package, but NETLINK interface to
the kernel.

Below is the output of what I configured with 'nm-connection-editor'.
Why is that output even localized?!

What is the issue with localization/no-localization?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]