failure with bridge devices

I'm running openSUSE Tumbleweed, with GNOME 3.16.2 and NM 1.0.6, and
have odd issues with networking.

Initially GNOME automatically configured the onboard ethernet and named
it "Wired Connection 1". I added a few VPN connections and all was fine.

A few weeks later I finally got around to reenable my winxp-tax VM. For
this I needed a bridge. The GNOME UI is appearently unable to handle
bridge. I was unable to get online, under the hood only the onboard
connection was enabled.

Later I found nm-connection-editor. This showed the bridge devices etc.
But in the end, since both seem to disagree about what is configured, I
removed the related config files from
/etc/NetworkManager/system-connections, used nm-connection-editor to
configure a bridge with the onboard ethernet. After a reboot it finally
worked. The GNOME UI is still unable to recognize the  bridge connection.
But in the end I was able to run the VM and all was fine again.

With todays TW snapshot the IPv4 part of the connection did not get up.
I found the nmcli command. It showed the bridge is online, but no IPv4
route was set. Dowing down and up showed that only the bridge came up,
but not the onboard device. Trying the GNOME UI did not get a connection

To my surprise, once I ran 'nmcli connection up bridge' the established
onboard connection from GNOME changed something, now the bridge came up
fine including IPv4. Up to now only IPv6 was usable to get outside.

So my questions:
Are there known bugs in the cooperation between NM and GNOME?
Are bridge devices fully supported? If so, why did NM not bringup
onboard before configuring bridge?
Does NM rely on the iproute2 package in any way?

Below is the output of what I configured with 'nm-connection-editor'.
Why is that output even localized?!


nmcli connection show br0-onboard                          br0-onboard
connection.uuid:                        e28ba628-68ec-4893-8fbd-49846c89009a
connection.interface-name:              enp2s0
connection.type:                        802-3-ethernet
connection.autoconnect:                 yes
connection.autoconnect-priority:        0
connection.timestamp:                   1443421196                   no
connection.permissions:                                --
connection.master:                      br0
connection.slave-type:                  bridge
connection.autoconnect-slaves:          -1 (default)
connection.gateway-ping-timeout:        0
connection.metered:                     unknown
802-3-ethernet.port:                    --
802-3-ethernet.speed:                   0
802-3-ethernet.duplex:                  full          yes
802-3-ethernet.mac-address:             1C:C1:DE:B9:BB:48
802-3-ethernet.cloned-mac-address:      --
802-3-ethernet.mtu:                     auto
802-3-ethernet.s390-nettype:            --
802-3-ethernet.wake-on-lan:             default
802-3-ethernet.wake-on-lan-password:    --
bridge-port.priority:                   32
bridge-port.path-cost:                  100
bridge-port.hairpin-mode:               no
nmcli connection show bridge                          bridge
connection.uuid:                        7dcdbbf1-26bb-4981-a837-a617d5de88f6
connection.interface-name:              br0
connection.type:                        bridge
connection.autoconnect:                 yes
connection.autoconnect-priority:        0
connection.timestamp:                   1443421195                   no
connection.permissions:                                --
connection.master:                      --
connection.slave-type:                  --
connection.autoconnect-slaves:          -1 (default)
connection.gateway-ping-timeout:        0
connection.metered:                     unknown
ipv4.method:                            auto
ipv4.gateway:                           --
ipv4.route-metric:                      -1
ipv4.ignore-auto-routes:                no
ipv4.ignore-auto-dns:                   no
ipv4.dhcp-client-id:                    --
ipv4.dhcp-send-hostname:                yes
ipv4.dhcp-hostname:                     --
ipv4.never-default:                     no
ipv4.may-fail:                          yes
ipv6.method:                            auto
ipv6.gateway:                           --
ipv6.route-metric:                      -1
ipv6.ignore-auto-routes:                no
ipv6.ignore-auto-dns:                   no
ipv6.never-default:                     no
ipv6.may-fail:                          yes
ipv6.ip6-privacy:                       0 (disabled)
ipv6.dhcp-send-hostname:                yes
ipv6.dhcp-hostname:                     --
bridge.mac-address:                     --
bridge.stp:                             no
bridge.priority:                        32768
bridge.forward-delay:                   15
bridge.hello-time:                      2
bridge.max-age:                         20
bridge.ageing-time:                     300

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]