Re: Annoying bug in NM1.0.0-8

On 04/19/2015 10:20 AM, Dan Mossor wrote:
Greetings, folks.

I and at least one other individual have noticed an annoying bug with
NetworkManager-1.0.0-8.fc22.x86_64 but we aren't sure of the root cause
so we can't legitimately file a BZ on it yet. The issue we're seeing is
that with a fully updated Fedora 22 Beta system, once NM is in operation
for a bit it starts to loose connectivity. Not total connectivity, but
partial. For example, I can run a search on Google for anything and get
back the usual tens or hundreds of results. but on a single page of
results I can only successfully open 2 or 3 of them.

Specifically, a few sites I'm noticing I can no longer reach:

However, all Fedora Project, Red Hat CentOS and GNOME links work just
fine. Pages from the Stack Exchange family of sites are hit and miss,
but mostly miss. Also, it is only http traffic - I can hit these sites
with ftp, ssh or rsync where supported. I have tried using Chrome,
Firefox, Konquerer, ReKonq, wget and curl and get the same result every
time. To aid in troubleshooting, I am providing a link to the pcap [0]
of my wget attempt against the RPM Fusion mirror site - it's
disappointing, really.

The only commonality I've discovered among the affected systems is that
they are using Intel wireless adapters. Specifically in my case, a
Centrino 2230 and a Centrino 2200. The other user I mentioned earlier
indicated that he believed the fault may lie in the routing tables, but
I have not confirmed or ruled this out yet - I'm still shooting in the

I know it is not network issues at large, as on this network I have
other devices - Android, ChromeOS, and Windows 8.1 devices - that all
work fine. In fact, on one of my affected systems, it was working just
fine on F21 and NM 0.9.10 before I updated it to F22 last night with
fedup. This points directly to F22 being at fault, but like I mentioned,
I don't know if it is NetworkManager or Intel Wireless drivers.

Thoughts? Concerns? Criticisms?


[0] - a shortened link to Google Drive, full link:

Ok, my wired networking problem has been hashed out - it was a physical layer issue. That led me to discovering that the problem is worse than I feared, it exists on wired networking also, and can't be tied to Intel drivers since both systems I tested this on have either a Qualcomm Atheros or Realtek gigabit ethernet NIC.

I have filed a bug.

Dan Mossor, RHCSA
Systems Engineer
Fedora Server WG | Fedora KDE WG | Fedora QA Team
Fedora Infrastructure Apprentice
FAS: dmossor IRC: danofsatx
San Antonio, Texas, USA

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]