Re: QMI support in network-manager-applet

Well from the pastebin at the bottom you can see where it posts:

modem-manager[14160]: <debug> [1367968641.827390]
[mm-broadband-modem-qmi.c:2922] dms_uim_get_ck_status_ready():
Facility 'corp-pers' is: 'deactivated'
modem-manager[14160]: <debug> [1367968641.827654]
[mm-broadband-modem.c:8704] iface_modem_3gpp_ussd_initialize_ready():
Couldn't initialize interface: 'USSD not supported'
modem-manager[14160]: <debug> [1367968641.827898]
[mm-broadband-modem-qmi.c:5847] messaging_check_support(): Messaging
capabilities supported by this modem
modem-manager[14160]: <debug> [1367968641.827952]
[mm-iface-modem-messaging.c:1113] load_supported_storages_ready():
Supported storages loaded:
modem-manager[14160]: <debug> [1367968641.827969]
[mm-iface-modem-messaging.c:1114] load_supported_storages_ready():
mem1 (list/read/delete) storages: 'sm, me'
modem-manager[14160]: <debug> [1367968641.827987]
[mm-iface-modem-messaging.c:1115] load_supported_storages_ready():
mem2 (write/send) storages:       'sm, me'
modem-manager[14160]: <debug> [1367968641.828004]
[mm-iface-modem-messaging.c:1116] load_supported_storages_ready():
mem3 (reception) storages:        'sm, me'
modem-manager[14160]: <debug> [1367968641.828108]
[mm-broadband-modem.c:8708] iface_modem_time_initialize_ready():
Couldn't initialize interface: 'Time not supported'
modem-manager[14160]: <debug> [1367968641.828187]
[mm-broadband-modem-qmi.c:7353] firmware_check_support(): loading
firmware images...
modem-manager[14160]: [/dev/cdc-wdm0] Sent message...
<<<<<< RAW:
<<<<<<   length = 13
<<<<<<   data   = 01:0C:00:00:02:01:00:13:00:49:00:00:00
modem-manager[14160]: [/dev/cdc-wdm0] Sent message (translated)...
<<<<<< QMUX:
<<<<<<   length  = 12
<<<<<<   flags   = 0x00
<<<<<<   service = "dms"
<<<<<<   client  = 1
<<<<<< QMI:
<<<<<<   flags       = "none"
<<<<<<   transaction = 19
<<<<<<   tlv_length  = 0
<<<<<<   message     = "List Stored Images" (0x0049)
modem-manager[14160]: [/dev/cdc-wdm0] Received message...
  length = 20
  data   = 01:13:00:80:02:01:02:13:00:49:00:07:00:02:04:00:01:00:47:00
modem-manager[14160]: [/dev/cdc-wdm0] Received message (translated)...
  length  = 19
  flags   = 0x80
  service = "dms"
  client  = 1
  flags       = "response"
  transaction = 19
  tlv_length  = 7
  message     = "List Stored Images" (0x0049)
  type       = "Result" (0x02)
  length     = 4
  value      = 01:00:47:00
  translated = FAILURE: InvalidQmiCommand

modem-manager[14160]: <debug> [1367968641.834468]
[mm-broadband-modem.c:8709] iface_modem_firmware_initialize_ready():
Couldn't initialize interface: 'Firmware not supported'
modem-manager[14160]: <info>  [1367968641.834605]
[mm-iface-modem.c:1203] __iface_modem_update_state_internal(): Modem:
state changed (unknown -> disabled)
modem-manager[14160]: <debug> [1367968641.834681]
[mm-serial-port.c:1003] mm_serial_port_close(): (ttyUSB0) device open
count is 0 (close)
modem-manager[14160]: <debug> [1367968641.834697]
[mm-serial-port.c:1019] mm_serial_port_close(): (ttyUSB0) closing
serial port...
modem-manager[14160]: <debug> [1367968641.836321]
[mm-serial-port.c:1050] mm_serial_port_close(): (ttyUSB0) serial port
modem-manager[14160]: <debug> [1367968641.836365]
[mm-base-modem.c:978] initialize_ready(): modem properly initialized

I'm not sure what the issue is but when I check nm-applet it doesn't
show the device, nor is wwan0 showing up in a "disconnected" state.

On Wed, May 8, 2013 at 1:37 AM, Aleksander Morgado
<aleksander lanedo com> wrote:
On 08/05/13 01:25, dag dg wrote:
Maybe I missed something but I'm getting the same result:

What do you mean with the same result? You now get the modem managed by
the Novatel plugin in QMI mode.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]