Re: Problem to add a broadband connection on NetworkManagerUserSettings

Hi guys,

I tried with SystemSettings before use UserSettings and really works, but when you create a connection with "SystemSettings", it's marked as "Available for all users", and when you use this kind of connection, you just can use once, the second time crashes the system, there is a lot of issues opened on launchpad about it, because of that I need to use UserSettings.

Happens for broadband and DSL connections, may be to wireless too, it's not just about connections created with my own code, I tried with nm-applet, if you check available for all uses, don't works.

If someone knows some workaround to get SystemSettings working, I can use it.

Thanks guys for your help, and sorry again about the "Legal message", it's not my faul, but I'll start use other email.


On Tue, 2010-01-19 at 16:45 +0100, Jirka Klimes wrote:
On Wednesday 13 January 2010 16:33:27 Maxwell Chiareli Xandeco wrote:
> I'm using Ubuntu 9.10, with your code I don't get errors but a
> connection is not added, nothing happens when I call AddConnection
> method.

I've investigated it a bit and found out that AddConnection is not supported
via D-Bus due to security reasons.
(src/gconf-helpers/nma-gconf-settings.c:add_connection() function)

If you use SystemSettings service instead of UserSettings, the connection
adding will work (just keyfile plugin).


Legal Disclaimer: The information contained in this message may be privileged and confidential. It is intended to be read only by the individual or entity to whom it is addressed or by their designee. If the reader of this message is not the intended recipient, you are on notice that any distribution of this message, in any form, is strictly prohibited. If you have received this message in error, please immediately notify the sender and delete or destroy any copy of this message

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]