Re: after execute test file d/l from git, wireless not ready, also cannot connect through Ethernet.

On Thursday 16 of December 2010 04:00:15 inthawadee C. wrote:
> Sorry for the vague information.
> First I downloaded the source file as described in NM developer webpage.
> >> git clone
> >> git:// cd
> >> NetworkManager
> >> ./ --prefix=/usr --sysconfdir=/etc --localstatedir=/var
> >> make
> >> sudo make install
> after doing follows the commands above and install packages it requested. I
> execute some files including
> ./NetworkManagers/examples/C/add-connection-glib
> ./NetworkManagers/examples/C/get-active-connections
> ./NetworkManager/libnm-glib/libnm-glib-test

That 's all right.

> NM still worked fine even I restart the computer for several times.
> However on the following day after turning the computer on, the NM-applet
> icon is spinning as if it tried to connect. It also shows that wireless not
> ready. The cable is always plugged.
> From nmcli command, it shows the status as connecting.
> Dec 16 08:05:42 BMW dhclient: DHCPACK of from
> Dec 16 08:05:42 BMW dhclient: execve
> (/usr/libexec/nm-dhcp-client.action, ...): Permission denied

The problem is that DHCP transaction is not successful due to the above error.
Probably, AppArmor is preventing executing /usr/libexec/nm-dhcp-client.action, 
because that's not the path used by Ubuntu NM package. The package uses 
/usr/lib/NetworkManager/nm-dhcp-client.action, see AppArmor profile

So you should update the profile and reload AppArmor.

More info:


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]