Re: wireless networking no longer works.

On Tue, 2009-02-03 at 11:34 -0500, Dan Williams wrote:
> On Sun, 2009-02-01 at 14:47 -0600, Tom Bourke wrote:
> > Hello all.  I have had fedora 10 installed on my laptop for some time
> > and networking had been good.  The network would even survive suspend
> > and hibernate.  Last week did a full reinstall of fedora 10 on 2
> > identical laptops.  Acer Aspire 3680-2633.  Atheros Communications Inc.
> > AR2413 802.11bg.  Every thing worked fine. Including wls network.
> What kernel version?  What's the output of "/sbin/lsmod | grep ath5k"
> and "/sbin/lsmod | grep ath9k" ?  It sounds a lot like flaky drivers.
> When you run into the problem of not being able to see networks you know
> are present, drop to a command-line and as root, run "iwlist wlan0
> scan".  Does the network show up there?  If it reports "No scan results
> available", the driver has a bug.  If your AP doesn't show up, try
> "iwlist wlan0 scan" again.  If the AP *still* doesn't show up, there's
> probably a driver bug.
> Dan
Than you for your time.  Currently both laptops are working fine at home
again.  Hers started showing networks after I let it sit for an hour or
so.  After that it took some doing to get it to connect.  Mostly a
combination of networkmanager restarts and reboots with some network
setting changes.  Now both go on line normally.

I did not know about iwlist command till after it started to show
networks, at that point it was showing my network AP just fine.  Took
more work to get an IP.

Current outputs from the above commands.
$ /sbin/lsmod | grep ath5k
ath5k                 112520  0 
mac80211              173668  1 ath5k
cfg80211               23816  2 ath5k,mac80211

ath9k shows nothing.

iwlist wlan0 scan shows my AP just fine right now.

Given that they now work I think I will wait till they fail again.  I
think there is/was a problem with the driver or NM on my setup but till
it shows again I am fine. Unless there is some other way to track down
when went wrong and prevent it from happening again. The other good news
is these are not mission critical units.

Thank you.  Other than this glitch both my wife and I are liking Fedora

> > Wife takes one to a hotel, I take other to a friends house.  Neither of
> > us can see wls networks.  Get home, ours do not show at all.  Set up an
> > extra AP with no security and broadcast SSID.  Nothing shows.  Multiple
> > reboots, and restarts of NM.  After one NM restart I got LOTS of selinux
> > errors so I disabled it and restarted NM again and I could see networks
> > again but could not stay connected for more than a sec or two.  Had
> > SElinux do a system wide relable at boot and also booted into windows XP
> > at the same time to check the card and AP.  Worked good. reboot into
> > Linux and I am able to use the wls again on my laptop.
> > 
> > I did the SElinux re-lable on the wife's laptop and now it can scan and
> > see AP's.  However it can not connect.  I can not boot into win XP to
> > "fix" the card. (I use to have to do this under fedora 9 and lower if
> > the laptop went to suspend, reboot would not do it)
> > iwlist shows the correct (open) AP but NM and firefox both show off
> > line.  I have looked on google and here but I have not found any
> > workable solutions.  Any one have an idea?
> > 
> > It HAS to work at home.  It also needs to work for my wife if she is
> > away from home, she loves using Linux but can not trouble shoot it,
> > thats what I am for.  Thank you for your time.
> > 
> > 
> > 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]