Re: More LCP echo problems

--On 24 October 2008 17:31 -0400 Dan Williams <dcbw redhat com> wrote:
¦ Looking at the manpage for pptp there are:
¦        --idle-wait <secs>
¦               Time to wait before sending a control connection echo request.  The RFC2637 default is 60 seconds.
¦        --max-echo-wait <secs>
¦               Time to wait for an echo reply before closing the control connection.  The RFC2637 default is 60 seconds.
¦ maybe that's what we want?

I've been testing various configurations and I'm getting some strange behaviour that's really confusing me!

I've tried making the VPN connection over the LAN connection (not useful in reality, but a handy test), and that works OK. The logs show it sending PPTP echoes and getting replies, and the connection stays up indefinitely.

However, over the mobile connection it times out, and the server log says this is because the *server* is sending LCP echoes and doesn't get a reply. There's no indication of PPTP echoes at all using this connection. The server is a Linux box running a fairly old 2.4 kernel. I suppose it may be it sets up pppd differently depending on the interface the connection comes in on (local LAN or external ADSL).

I then tried setting up a VPN session over the LAN from the command line using pppd + pptp directly. I used essentially the same command line that NM creates (extracted from ps), but using the secrets files instead of the plugin. Running this connection over the LAN failed after 2 minutes, and the client log says it was failing to get PPTP echoes. However, these echoes are sent and replied when virtually the same command is launched by NM.

As I said, I'm confused!

My intention was to find what kind of echoes were failing and what command parameters could be tweaked to fix it, but I can't get any consistency so I'm at a loss :(

Any ideas?

Cheers, Rick

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]