Re: Some questions -- wpa_supplicant

Hash: SHA1

Robert Moskowitz wrote:
> Ryan Novosielski wrote:
>> Hash: SHA1
>> Please keep replies on-list for everyone's benefit.
> oops.  Just did a reply, am use that on most lists this replys to the 
> list, not to the original sender...
> For this list, I have to do a reply to all, the edit the to/cc headers 
> (using Thunderbird 1.5)

There is a "Reply-To-List" extension out there that I mean to see if I
can dig up. It only works on Thunderbird 1.x -- the new one that is easy
to find only works on patched 2.x and the yet-unreleased 3.x. I'll let
you know if I find it.

(sorry to go off-topic)

>> Robert Moskowitz wrote:
>>> Ryan Novosielski wrote:
>>>> Hash: SHA1
>>>> You might want to write a more specific subject next time, for
>>>> everyone's benefit. Everyone who writes to the list has "some questions."
>>>> Robert Moskowitz wrote:
>>>>> Hello, I am new here.  Running 0.6.4 in Centos 5.1 on an HP nc2400
>>>>> notebook with the Intel ipw3945 dkms code from rpmforge.
>>>>> I just switched my operation over the this nc2400 from my old nc4010
>>>>> which had an Atheros card using the madwifi dkms code from rpmforge
>>>>> and I did everything via wpa_supplicant.conf (and the wpa_cli program!).
>>>>> So with this install, I could not get the wpa_supplicant working. 
>>>>> Seems like it only supports the ipw2200 card?  And I found
>>>>> NetworkManager; good job! So far  :)
>>>> Incorrect. It probably best supports that card, but as far as I know,
>>>> all Intel cards are supported. Really any card that has a driver
>>>> supporting Wireless Extensions.
>>> Well I tried running:
>>> /usr/sbin/wpa_supplicant wpa_supplicant -B -D ipw3945 -i eth1 -c 
>>> /etc/wpa_supplicant/wpa_supplicant.conf
>>> And I get Unsupported driver 'ipw3945'
>>> So I read the man wpa_supplicant and find that I should say -D ipw and
>>> that only ipw2200 is supported.  But I tried anyway:
>>> /usr/sbin/wpa_supplicant wpa_supplicant -B -D ipw -i eth1 -c 
>>> /etc/wpa_supplicant/wpa_supplicant.conf
>>> And still got unsupported device.
>> No, you want wext for basically all modern cards, not ipw. Those other
>> drivers are really legacy holdovers, and hopefully will go away.
> OH.  I missed this one.  Well actually I recall that how I finally even 
> got NetworkManager working was to edit /etc/sysconfig/wpa_supplicant to 
> have:
> wpa_supplicant:DRIVERS="-Dwext"
> I did not 'get' this previously!

In fact, I'm pretty sure that NetworkManager ONLY supports cards that
conform to -Dwext -- wpa_supplicant can also use all the others.

- --
 ---- _  _ _  _ ___  _  _  _
 |Y#| |  | |\/| |  \ |\ |  | |Ryan Novosielski - Systems Programmer II
 |$&| |__| |  | |__/ | \| _| |novosirj umdnj edu - 973/972.0922 (2-0922)
 \__/ Univ. of Med. and Dent.|IST/AST - NJMS Medical Science Bldg - C630
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla -

fn:Ryan Novosielski
adr;dom:MSB C630;;185 South Orange Avenue;Newark;NJ;07103
email;internet:novosirj umdnj edu
title:Systems Programmer II
tel;work:(973) 972-0922
tel;fax:(973) 972-7412
tel;pager:(866) 20-UMDNJ

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]