Re: Adding PPTP to NM 2

On Fri, 2005-11-18 at 01:25 +0000, Antony J Mee wrote:
> Hi Tim,    (cc. Steev and the NM list)
> So people know what's going on I'll copy this to all you NM folk.
> So I paused my WPA fiddlings again (hard) and pretty much finished this 
> PPTP mod (less hard) of your OpenVPN code.  Not that I've done anything 
> very clever :-)  It's not perfect ie. it seems to do all the necessaries 
> but there are some strange bits like the fact that the passwords have to 
> be stored in /etc/ppp/chap-secrets at the moment (a ppp relic I haven't 
> figured a workround for).

I don't have a VPN setup just yet - a mail was sent to my local lug list
recently, and I might pick up some of those machines just so I can setup
a minor network - couple of 486s and a couple of P1's...

> There's also a load of unnecessary OpenVPN stuff in the PPTP config 
> dialogues that I need to clear out perhaps replacing them with the 
> pptp/ppp options that I've hard coded into the start_binary code for the 
> moment.
> I'm just trying to test it now.
> I've had difficulty compiling it though (had to bodge some stuff)... 
> it's this intltoolize stuff that Steev mentioned on the list a while 
> back (I like him am a Gentoo user):
> ------------------------------
> # --prefix=/usr --sys-confdir=/etc
> ~snip~
> Running glib-gettextize... Ignore non-fatal messages.
> Copying file mkinstalldirs
> Copying file po/
> Please add the files
>   codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
>   progtest.m4
> from the /usr/share/aclocal directory to your autoconf macro directory
> or directly to your aclocal.m4 file.
> You will also need config.guess and config.sub, which you can get from
> Running intltoolize...
> intltoolize: 'po/' is out of date: use '--force' to overwrite
> --------------------------
> Perhaps you know more about this intltoolize stuff?
> Or maybe Steev will read this and tell me what he did. I meant to mail 
> him earlier -
> I couldn't find a sufficient answer in the Gentopia overlay or in the 
> archive.
> It seems to be something to do with autogen copying the wrong 
> (glib-gettextize as opposed intltoolize) version of into po/.
> tOnY
> PS. yes, PPTP seems to go through a NAT box in either direction just fine.
>        sadly, MS-CHAP-v1/v2 pretty much suck :-)

Good to hear you are getting it working - The way that I got around the
intltoolize stuff was, I ran autoreconf or autoconf (fairly certain it
was autoreconf)

Just ran that, and then ran configure, and then I run make dist to
create a tarball - that is then hosted on my site since I've not seen
any tarballs released anywhere.

Hope that helps, any other questions, let me know and I will double
check, I am working 3:30pm - midnight CST until next Tuesday, and then I
switch to 9:45am to 6:15pm CST.

-- Steev

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]