Re: SCREEN command and MCEdit under SLES9

Hello Anton,

On Fri, 9 Jun 2006, Anton Monroe wrote:

On Fri, Jun 09, 2006 at 07:18:17PM +0300, Pavel Tsekov wrote:
On Fri, 9 Jun 2006, Anton Monroe wrote:

My own problem is using MC when SSH-ing from OS/2 to a Linux machine.
I've tried 'mc -x' and a variety of $TERM settings on each end in an
unsystematic way, but haven't hit on a combination that works well.

Don't worry, I'm not asking the MC developers to solve that problem.
But if anyone has some hints or pointers to sources of information about
terminal problems, we could add them to the FAQ file.

First of all - what is that problem ?

Argh.  I wasn't very clear, was I?  The context was the thread about
the screen command and getting various PF keys to work correctly.

Depending on how I configure SSH, $TERM, and MC, certain keys don't do
anything, or they print control sequences.  Using TERM=xterm or
TERM=xterm-color comes closest to getting the keys right, but it causes
beeping noises (when the screen redraws?).

Judging from what you wrote above screen is not ivolved in your setup ?! Anyway - if you want you problem solved, please, exlpain the exact setup both on the client and on the server. I.e. what terminal emulator are you running on the client machine (the one you ssh from), what does TERM contain when you login on the server, what does it contain after your start screen, etc, etc. If you have changed any configuration files, environment variables, etc, in your attempts to fix the problem you have to let us know what were those changes.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]