Re: ftpfs and '.' and '..' directory entries

Hello Frank,

On Thu, 20 Jul 2006, Frank Dietrich wrote:

Pavel Tsekov <ptsekov gmx net> wrote:
On Sun, 9 Jul 2006, Frank Dietrich wrote:
when I access an FTP server which include in the directory
listing the '.' and '..' entries I only see the directory name.
When I change into this directory I only see the directory itself
as an infinite loop.
I tried it with MC from CVS but couldn't reproduce it. Would you mind
running MC with ftp logging enabled and sending the log file to the
list ?

I attach the logfiles. One with mc in FTP active/passive mode and one
from a normal console ftp session.

Seems like this particular ftp server doesn't support passing arguments
to the LIST command. I've found such ftp server installation on the internet (thanks to google) and tried different variations of the list
command - all of them returned the contents of the current directory.
Anyway, you could still use MC to work with such amputated ftp servers -
you have to turn on the 'ftpfs_first_cd_then_ls' parameter in your
mc ini file ($HOME/.mc/ini). In fact this option has been made the default
for some time now but apparently you have and older MC. I hope this helps.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]