Re: 4.6.0-pre1: cpio errors on RPMs

Hi MCers, hi Pavel,

On Mon, Aug 26, 2002 at 12:23:35 -0400, Pavel Roskin wrote:

        Open=%cd %p#ucpio
        View=%view{ascii} cat '%f' | cpio -ictv

Confirmed, and I have nothing blocking this in ~/.mc* .

First, this is what I have:

eedmoba sun115:~ > which mc                                                    
eedmoba sun115:~ > ldd `which mc`                                              =>         /opt/proj/WDM/tools/lib/ =>    /usr/openwin/lib/ =>   /usr/openwin/lib/ =>   /usr/openwin/lib/ =>        /usr/lib/ =>   /usr/lib/ =>         /opt/proj/WDM/tools/lib/ =>      /opt/proj/WDM/tools/lib/ =>     /usr/lib/ =>    /usr/lib/ =>     /usr/lib/ =>  /usr/openwin/lib/ =>    /usr/lib/
eedmoba sun115:~ > mc --version                                                
GNU Midnight Commander 4.6.0-pre1
Virtual File System: tarfs, extfs, ftpfs, mcfs
With builtin Editor
Using system-installed S-Lang library with terminfo database
With subshell support as default
With support for background operations
With mouse support on xterm
With support for X11 events
With multiple codepages support

1) Describe what you did (write "I pressed F3", NOT "I entered the file")

a) I ran "mc" without any options.
b) I changed into a directory containing some archives, among them RPMs
   and SRPMs.
c) I moved the file selector/cursor to "autotrace-0.28-mn1.src.rpm".
d) I pressed the "Enter" key and got the RPM/SRPM display (as


   (I did _not_ expect to see anything special when pressing "Enter" on
   "CONTENTS.cpio", perhaps I should configure mc so that it displays
   files which are bound to special features in a different way. Am I
   hinting at things which you don't understand again? Please just

e) I moved the file selector/cursor to "CONTENTS.cpio"
f) I pressed "F3" (obviously bound to "File -> View").
g) I got a popup "window" (in red btw.) saying:
   ------------ Error ------------
   |                             |
   | cpio: premature end of file |
   |                             |

   (Please excuse the imitation of line drawing characters in this
   email. The popup actually has proper lines.)
h) Further:
   alternative I) I clicked with the mouse into the mc window (which in
   in an xterm). The popup disappeared.

   alternative II) I pressed "Escape" twice (my usual way to escape
   from unwanted menus, popups or anything on can escape from), and
   another popup window appeared:
   -------------- Error ---------------
   |                                  |
   |  Empty output from child filter  |
   |                                  |

   This window I either got closed clicking my mouse once inside
   mc's xterm or pressing "Escape" twice.

2) Describe what you expect to get ("I expect a listing to appear)

My expectations were not fulfilled in the described steps following
"f)", i.e. in "g)" and "h)". I do _not_ know what to expect when
pressing "F3" on a cpio file. On any "regular" (not specially handled)
file, I expect to see the contents of the file, as ASCII or perhaps as
Hex, ar whatever any automatic mechanism might want to do to display a
file's contents. Perhaps, knowing that cpio is handled just like other
archive formats, I would/should have expected to see a content listing
somewhat like what "cpio -itv" produces.

3) Describe what you got (quote error messages _exactly_, don't rephrase 

That's what I did in my original mail, I wrote I got "cpio: premature
end of file" and "Empty output from child filter" in succession. I now
realize that there are ways to get and ways not to get these messages.
Glad you asked for "1)".  :-)

Just to go sure, here output from _inside_ mc (just to ensure that GNU
cpio is being used):

$ which cpio
$ cpio --version
GNU cpio version 2.4.2

There was no reply to my last e-mail, not even in private.  That's very
characterisic for many users of Midnight Commander - as soon as there is
another way to do something (Enter vs. F3), nobody cares why the original
approach (pressing F3 on cpio archives) didn't work.

That's characteristic of people who have a life i.e. work beside
debugging useful tools. I try to help, but my company better not even
know about it... (Too late now, they're throwing me out. ;->>)

That's one of the reasons why some problems remain unfixed for years.

I honor your high opinion of open source development, but my experience
is often that I find bugs, find workarounds/fixes, report them (in a
friendly manner IMO), and they never get commented, let alone fixed. I
have two recent examples pending which I tried to revive yesterday, one
with the build of "mutt" on Solaris 2.6, one with the build of "file"
on any platform. No response for months! I'm glad you're different. :-)

And that, in turn, may be one of the reasons why so many bugreports for
Midnight Commander (compared to other projects) don't include its version
number - people think that nothing changes between versions after seeing
the same bugs over and over again!

I will not quote the subject of this thread here ;-) but I assume you
didn't mean me. :)

Thanks for listening,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]