How to Get Top level menus to open (Left, File, Options, Comand, Right)?

Hi Paval,

I'm using mc 4.5.0 (at the moment because I can't resolve the GLIB problem
right now) on RedHat 6.2 i86 and I'm using two different ssh terminals
(putty and SecureCRT) that go through gateways to get to the system that
hosts mc.  

When I run mc from a Gnome XTerm, everything works fine of course. But in
general from the remote terminals, I am not getting X or Mouse actions.  

1.  How do I get the "Left" menu - or any of the other menus to open without
the mouse working?  I can't use function keys.  I can't use Alt-Tab because
that's Windows. I can use any control key.  I can use Esc, and I seem to be
able to use Alt keys.  

2.  Are you familiar with these or other ASCII terminal emulators?  
o  It's unlikely that I can get either of these to perform X Server funtions
on their own - although SecureCRT claims to have X11 forwarding capability
(if you have another X Server).  

o  In Putty, when I turn XTerm mouse actions on, it does highlight each of
the top level menu names and it also highlights the scrollbar - but the
menus fail to open and the scroll bar doesn't scroll.  For instance, if I
click on the word "Left" and then click the center button five times, the
command prompt line reads:

    bash$ LeftLeftLeftLeftLeft

3.  I can't map keys to get the menus to open either because I can't get the
Options menu open in the first place to get to the key mapping capability.  

4.  Is there a complete list of all keyboard actions somewhere?  I've
learned quite a bit by hunting around - such as the miraculous Alt-? which
allegedly does a tree fgrep search. But *not* how to get top level menus

5.  Is there a FAQ that applies to using mc (and/or similar programs) with
terminal emulators?  

MC is is miraculous in it's appearance similarity to Norton - on putty for
instance, when I start it with mc -c.  It looks just like it should.  I just
wish I could press Alt-F or something and have the File menu open up...

Thanks for your help.

Regards and best wishes,

Rich Katz 

-----Original Message-----
From: Pavel Roskin
To: Richard Katz
Cc: mc gnome org
Sent: 7/12/2001 9:49 PM
Subject: RE: Installation problems

Hi, Richard!

Config.log now shows the messages below (after I installed glib
1.2.10).  It
says it's finding GLIB 1.2.6.

I tried running /sbin/ldconfig - that didn't help.

Sorry I just don't know this: How do I remove the old version of GLIB?

If you are using RedHat you should use "rpm -e" to remove packages.  But
you probably don't want to do it with glib, since many packages depend

MC requires glib-1.2.0 or above.  To my best knowledge MC has never
required a higher version.  glib-1.2.6 should be fine.

 printf("\n*** An old version of GLIB (%d.%d.%d) was found.\n",
               glib_major_version, glib_minor_version,
        printf("*** You need a version of GLIB newer than %d.%d.%d.

This is quite useless.  I only can deduce that this test failed (since
was dumped to config.log), but I don't see how, i.e. which of those
printf()s was actually executed.  It must be below this part.

Whenever you are reporting problems in software ALWAYS mention what
version of software you are using.

Please don't quote parts irrelevant to your message.

I'll ignore all your further messages if you don't mention what version
Midnight Commander you are using.

Pavel Roskin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]