Re: Local rendering creates blank tiles

Am 08.06.2010 23:45, schrieb Jiří Techet:
On Sun, Jun 6, 2010 at 17:50, Patrick Salecker<patty9999 gmx de>  wrote:
Am 06.06.2010 15:21, schrieb Simon Wenner:

On 06.06.2010 14:43, Patrick Salecker wrote:
while I was testing the python memphis bindings of libchamplain, I
noticed that local rendering through libchamplain doesn't work at all on my

"memphis/demos/" and
"pymemphis/examples/" render the tiles correct, but
"libchamplain/demos/local-rendering" shows only an arc:

Are you sure that you are looking at the area that contains the data? Any
error messages in the terminal?
Maybe these are old tiles from champlain's cache. Try to delete the cache.
Now I know a workaround:
When I run "./local-rendering", select "Local Map" and click on "Einpassen"
(locale is de_DE.utf8), is see blank tiles and no terminal output.
When I run "LANG= ./local-rendering" it works fine.

Any ideas why this happens?

Interesting. From your last email it seems that the same happens even
with the normal (non-python) demo, right?

The only idea I have is that libmemphis parses the xml map data file
incorrectly because it opens the file in different encoding (I think
GTK normally uses locale encoding and not UTF-8, which might be the
problem). But it could be something else too.

Yes, but only with libchamplain. The demos from memphis and pymemhis are working correct.

I compiled libchamplain with debugging and compared the logs from local-rendering with and without locale with diff. The only difference I noticed, was that the coordinates in the debug messages have points instead of commas.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]