Re: Q: Using 2.5.5-2 with VS .Net?

leyland needham said the following at 2005-02-12 12:42 :
I don't get this problem when I run my applications built in VS, and
my libatk-1.0.0.dll also doesn't have atk_text_clip_type_get_type, I
don't know if I have the latest gtkmm installed, it's been probably
over a month since I've had a chance to do anything.

I just downloaded the libraries (2.5.2-2-devel) yesterday; I don't know if that might be an issue.

Anyway, assuming for now that something fundamental hasn't been broken in the past month or so, the following trivial program produces the same error:


#include <gtkmm/main.h>

int main(int argc, char *argv[])
  Gtk::Main kit(argc, argv);

  return 0;


I created a new project and followed precisely your instructions; the only additional step needed was that VS had a complaint about pre-compiled headers, so I turned off the option to use precompiled headers (which sems to be on by default). I added no libraries or anything else to the project.


I see that there is an executable file called gtkmm-demo.exe included with the distribution. Executing that causes the same error to occur.

It seems like maybe there is something fundamentally misconfigured somewhere, but I have no idea what :-(

Hmmm again....

So, wondering if the system might be confused because I have a dev-c++ that works OK, I renamed the GTK\2.0 directory and re-installed from scratch, then rebuilt the project and ran it. Still getting the same error :-(


Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]