Re: [GtkGLExt] GtkGLExt - (cross) building troubles

Hello again,
I have finally built the GtkGlExt libraries - before that I had a "big mess"
in files when I was always copying some files from and to directories, again
copy, something move, etc... . So I realized to set up again my building
environment from scratch, and it helped.
"But" I have successfully built it "only" with these configure parameters:

    ./configure --host=i386-mingw32 --disable-glibtest --disable-gtktest

Now I want to build "gtkglextmm" (the C++ binding of GtkGlExt) "against"
GtkGlExt, but I have the same error I had with building GtkGlExt:

    checking for GtkGLExt - version >= 1.0.0... no
    *** Could not run GtkGLExt test program, checking why...
    *** The test program failed to compile or link. See the file config.log
for the
    *** exact error that occured. This usually means GtkGLExt is incorrectly
    configure: error: GtkGLExt not found

I can again use the configure command for gtkglextmm with these arguments to
bypass that error:

    ./configure --host=i386-mingw32 --disable-gtkglext-test

...and it will be configured without problems but then I get this error
after calling "make" command:

    make  all-recursive
    make[1]: Entering directory `/home/petike/src/gtkglextmm-1.2.0'
    Making all in tools
    make[2]: Entering directory `/home/petike/src/gtkglextmm-1.2.0/tools'
    Making all in extra_defs_gen
    make[3]: Entering directory
    /bin/bash ../../libtool --mode=link i386-mingw32-g++  -g -O2 -Wall
-mms-bitfields   -o generate_extra_defs.exe  generate_defs_gtkglext.o 
-L/windows/lib -L/windows/gtkmm/lib -lgtkglext-win32-1.0
-lgdkglext-win32-1.0 -lglu32 -lopengl32 -luser32 -lkernel32 -lgtkmm-2.4
-lgiomm-2.4 -lgdkmm-2.4 -latkmm-1.6 -lgtk-win32-2.0 -lpangomm-1.4
-lcairomm-1.0 -lglibmm-2.4 -lsigc-2.0 -lgdk-win32-2.0 -latk-1.0 -lgio-2.0
-lgdk_pixbuf-2.0 -lpangowin32-1.0 -lgdi32 -lpang   -lstdc++
-lglibmm_generate_extra_defs-2.4 -lgmodule-2.0 -lglib-2.0 -lintl  
      -L/windows/lib -L/windows/gtkmm/lib
/windows/lib/libgdkglext-win32-1.0.dll.a -lglu32 -lopengl32 -luser32
-lkernel32 -lgtkmm-2.4 -lgiomm-2.4 -lgdkmm-2.4 -latkmm-1.6 -lgtk-win32-2.0
-lpangomm-1.4 -lcairomm-1.0 -lglibmm-2.4 -lsigc-2.0 -lgdk-win32-2.0
-latk-1.0 -lgio-2.0 -lgdk_pixbuf-2.0 -lpangowin32-1.0 -lgdi32
-lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0
-lintl -lstdc++ -lglibmm_generate_extra_defs-2.4 -L/windows/lib
    : No such file or directory
    make[3]: *** [generate_extra_defs.exe] Error 1
    make[3]: Leaving directory
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/petike/src/gtkglextmm-1.2.0/tools'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/petike/src/gtkglextmm-1.2.0'
    make: *** [all] Error 2

I think there is a problem with the arguments "--disable-<something>" - when
the configure script wanted to run some test program but it couldn't (I
don't know why) - and if I find "why" - maybe I will solve also the other

Probably there is some problem with "dynamic libraries" (gtk, glib,
gtkglext) - maybe I should set some environment variable (some "LD_RUN_PATH"
or "LD_LIBRARY_PATH"), but I don't know too much about these steps (I am
good at "writing" programs in c++, not in "compiling" them).

Do you someone know, what should I do next (I am starting to be very

P.S.: Answer to "Ralf Corsepius" ("... My wild guess is your cross-toolchain
might be incomplete or miss-configured ..."):

I tried also another version of mingw cross toolchain (the version which I
installed though "aptitude" in Ubuntu) and there were the same problems. So
I think there is problem with something different.
View this message in context:
Sent from the Gnome - GtkGLExt mailing list archive at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]