Re: Compiling Glib 1.223 on win xp

On Wed, May 25, 2011 at 3:18 AM, RAPPAZ Francois
<francois rappaz unifr ch> wrote:
When I run the makefile.PL script, I got a lot of
Note (probably harmless): No library found for -lgobject-2.0
Note (probably harmless): No library found for -lgthread-2.0
Note (probably harmless): No library found for -lglib-2.0
Note (probably harmless): No library found for -lintl
Note (probably harmless): No library found for -lkernel32

That I find strange since I have all these (I believe) in my IC:/Prog/gtk_2.16.6 folder.

You can have these files in any folder you want, but if I recall
correctly, MakeMaker only checks for files using your %PATH
environment variable, so I would say "C:/Prog/gtk_2.16.6" is not in
your %PATH.  You can also add these missing libraries by hand to your
Makefile, see below.

Following a thread on perlmonks
I tried to add
  INC => q[-IC:/Prog/gtk_2.16.6/include/glib-2.0 -IC:/Prog/gtk_2.16.6/lib/glib-2.0/include -I.],
  LIBS => q[-LC:/Prog/gtk_2.16.6/lib -lgobject-2.0 -lglib-2.0 -lintl -liconv -lgthread-2.0],

In the writemakefile call Âin the middle of the Without effect unfortunately.
Looking at the I have, I can see that INC is not an argument to the WriteMakeFile.

Did you see the poster's suggestion to add the missing libraries to
the EXTRALIBS and LDLOADLIBS variables in the Makefile?  This means
that all the libraries listed in your output of 'perl Makefile.PL'
above should be added to those two environment variables in the
Makefile.  Do you have libintl and libkernel installed on your Windows
machine?  libintl is available for Windows on the GTK website, but I
don't remember where libkernel comes from.  MinGW perhaps?

At this point I have to ask why you're not using Camelbox.  All this
work is done for you already, you just have to run the installer and
let it do it's magick.  It looks like the only downside to running
Camelbox for you would be the fact that you have different versions of
Perl and GTK installed and listed in your %PATH environment variable,
and you would need to clean up your %PATH (remove any GTK and Perl
paths not related to Camelbox) prior to trying to use Camelbox.  This
could be done quite easily by using a DOS batch file, and you would
not need to make any systemwide changes.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]