Re: [gtk-osx-users] Issue with building GTK2.x for "modulesets" set (librsvg)

Thanks for the pointers.


From: John Ralls <jralls ceridwen us>
Sent: Monday, March 7, 2016 4:20 PM
To: Miroslav Rajcic
Cc: gtk-osx-users-list gnome org
Subject: Re: [gtk-osx-users] Issue with building GTK2.x for "modulesets" set (librsvg)

On Mar 7, 2016, at 1:07 AM, Miroslav Rajcic <mrajcic hotmail com> wrote:

This works OK now, but I noticed a new issue when configuring gtksourceview library (I never seen this one 

Running glib-gettextize... Ignore non-fatal messages.
Copying file po/

Please add the files
 codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
from the /Users/helix/gtk/inst/share/aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from

Running gtkdocize...
Running intltoolize...


config.status: executing po/stamp-it commands
config.status: error: po/ was not created by intltoolize.
*** Error during phase configure of gtksourceview: ########## Error running ./ --prefix 
/Users/helix/gtk/inst    *** [1/1]

I've googled, jumped into jhbuild shell and tried to apply first 3 commands from here:
then exited the shell and retried configure phase. Unfortunately, I still get the same error.

You can ignore all of that noise about copying m4 files from aclocal to a local macro directory. It has 
nothing at all to do with intltoolize; that problem is caused by gtksourceview's trying to use 
both gettext macros and intltool macros.[1] You'll have to take that up with the gtksourceview devs.

John Ralls

[1], citing

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]