Re: [gtk-osx-users] Using localization with "Application" menu with the gtk mac integration library.




On Nov 21, 2014, at 11:49 AM, Joshua Pettus <jshpettus gmail com> wrote:

I’d be happy too. Almost done and I made sure to do the commit messages as done in the source, but I have 
some basic questions.  What constitutes as a comment? Is it each line added and taken away or is it each 
section in the patch file? Is there a way I can get diff to recognize the GtkosxApplication.string.lang 
files as not being a binary?  Otherwise it just says the two are different and leaves it at that.

On Nov 21, 2014, at 12:25 PM, Joshua Pettus <jshpettus gmail com> wrote:

Ok, I found a solution to my first question, but I really don’t understand the git format-patch HEAD^ 
command. running it just downloads the last comment done as a .patch file.  and what is ^s?  how is this 
suppose to effect my patch file?

Not comment, commit.

git format-patch HEAD^ makes a nice git-formatted patch file ready to upload to BZ. The format is better than 
diff, which appears to be what you used, because it includes the commit message and sets you as the author. 
git am or git apply recognize that extra information and make the appropriate changes in the target repo.

The bit about adjusting the ^s meant that if you wound up with two commits you’d say `git format-patch 
HEAD^^`, if 3 commits `…HEAD^^^` and so on.

So first you make your changes. To change the names of the files you say e.g. 
  git mv strings/GtkOSXApplication.fr strings/GtkosxApplication.fr

Since it’s really two subjects, I’d do it by making the changes to gtkosxapplication_quartz.c and the strings 
themselves and commit that with an appropriate comment, then rename the files (git mv will add the files to 
the index), commit that with a different comment “Change string file names so that they work with 
case-sensitive file systems.”, then run
  git format-patch HEAD^^
to make the two patches and upload them.

BTW, in the bug report you said that it was Kevin Berningham who did the code, so perhaps you should pass his 
name and email as the argument to the —author option in the first commit.

Regards,
John Ralls



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]