Re: [gtk-osx-users] Building on PPC fails

The saga continues...

>>>>  Ok, any hint on how such a module could look like?
>>>  IIRC, cups has no other dependencies, so I'd think it would be just
>>>     <repository type="tarball" 
>>>  href=""; />
>>>     <autotools id='cups' autogen-sh="configure">
>>>         <branch 
> module="software.php?VERSION=1.6.1&FILE=1.6.1/cups-1.6.1-source.tar.bz2" 
>>>  version="1.6.1" />
>>>     </autotools>
>>  I have tried adding this into a cups.modules file under 
> ~/Source/jhbuild/modulesets and then running
>>  'jhbuild build cups' but that's not quite it.  Do you have a 
> pointer on how to write a modules file?  How does jhbuild know the items it can 
> build?
> Jhbuild builds everything that is either included in the "modules" 
> variable (which can also be passed in the --modules argument) or a dependency of 
> one of those.

Ok, I have added the following file as ~/Source/jhbuild/modulesets/cups.modules

<?xml version="1.0"?>
<!DOCTYPE moduleset SYSTEM "moduleset.dtd">
<?xml-stylesheet type="text/xsl" href="moduleset.xsl"?>

 <repository type="tarball" name="cups" href=""; />
    <autotools id='cups' autogen-sh="configure">
        <branch repo="cups" module="software.php?FILE=1.6.1/cups-1.6.1.tar.bz2" version="1.6.1"/>


and included it in ~/Source/jhbuild/modulesets/gtk-osx.modules

I can then run 

jhbuild -m ~/Source/jhbuild/modulesets/gtk-osx.modules build cups

which doesn't really work (jhbuild complains about the '?' or '=' character) but after downloading cups by hand and extracting it, the above line succeeds. 

Unfortunately, there is also an error here:

Compiling dest.c...
dest.c: In function ‘cupsEnumDests’:
dest.c:967: error: ‘kDNSServiceFlagsShareConnection’ undeclared (first use in this function)
dest.c:967: error: (Each undeclared identifier is reported only once
dest.c:967: error: for each function it appears in.)
make[1]: *** [dest.o] Error 1
make: *** [all] Error 1

I haven't looked into this further.  Have you been able to compile cups for Tiger?
>>>>  Back to the build on PPC/Leopard for the 10.4u SDK.  
> meta-gtk-osx-core 
>>>  builds now, but when I start gtk-demo the following gets printed and 
> the 
>>>  application terminates after a couple of seconds without any window 
> ever opened:
>>>>  **
>>>>  Pango:ERROR:pangocairo-fontmap.c:79:pango_cairo_font_map_new: code 
> should 
>>>  not be reached
>>>>  Abort trap
>>>>  The corresponding lines in pangocairo-fontmap.c:79 are:
>>>>  PangoFontMap *
>>>>  pango_cairo_font_map_new (void)
>>>>  {
>>>>    /* Make sure that the type system is initialized */
>>>>    g_type_init ();
>>>>  #if defined(HAVE_CORE_TEXT) && defined (HAVE_CAIRO_QUARTZ)
>>>>    return g_object_new (PANGO_TYPE_CAIRO_CORE_TEXT_FONT_MAP, NULL);
>>>>  #elif defined(HAVE_CAIRO_WIN32)
>>>>    return g_object_new (PANGO_TYPE_CAIRO_WIN32_FONT_MAP, NULL);
>>>>  #elif defined(HAVE_CAIRO_FREETYPE)
>>>>    return g_object_new (PANGO_TYPE_CAIRO_FC_FONT_MAP, NULL);
>>>>  #else
>>>>    g_assert_not_reached ();
>>>>    return NULL;
>>>>  #endif
>>>>  }
>>>>  Have you seen this before?
>>>  No, but ISTR Behdad decided that he couldn't support ATSUI any 
> more. He 
>>>  thought that there was enough of CoreText already in Tiger so that it 
> would 
>>>  work, but I guess not.
>>  Is Behdad on this mailing list and maybe know more?  From the few lines of 
> code I would have assumed that HAVE_CORE_TEXT should be defined.
> No. You can find him in the Gtk IRC channel or on gtk-i18n-list lists gnome org.

Ok.  Well, it's a pity that it's not so easy to forward this problem to him.  I am not using IRC and the other list seems the wrong place to report this problem.
>>>  You'll have to build meta-gtk-osx-freetype before 
>>>  meta-gtk-osx-core. That will provide the pangofc2 backend.
>>  I tried that and that fails with this error message:
> Fixed in 
> Get 0.9.10 or later.
I have done the following.  I updated the version of harfbuzz to 0.9.10 in ~/Source/jhbuild/modulesets/gtk-osx-bootstrap.modules and then ran

jhbuild -m ~/Source/jhbuild/modulesets/gtk-osx.modules build meta-gtk-osx-freetype

which successfully built the new version of harfbuzz.

I then deleted 

rm -rf gtk/source/gtk+-2.24.13/
rm -rf gtk/source/cairo-1.12.6/ 
rm -rf gtk/source/pango-1.32.4/

removed the corresponding lines in ~/gtk/inst/share/jhbuild/packagedb.xml and rebuild gtk by:

jhbuild build meta-gtk-osx-core

Did I miss a dependency maybe?

gtk-demo starts now, does not give any error message or other warning (or any output at all in the shell), but the window does not show any text (see attached screenshot).  I opened a sample demo with a GtkEntry and also the GtkEntry is empty.  The cursor is shown and moves forward when entering text but no text is visible, like white text on white background.

Any idea?

> That said, it's getting difficult to keep developers to remember to check 
> for functions supported by 10.4. There was yet another bug [1] submitted about 
> it yesterday. Unless you have a bunch of users who are stuck on really old macs 
> for some reason, it's a lot easier to support Leopard-and-later.

I am not yet ready to give up.  It seems we are very close.

Best regards,


Attachment: gtk-demo-no-text.tiff
Description: TIFF image

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]