Re: [gtk-osx-users] PyGTK on Lion

On Oct 24, 2011, at 12:38 AM, Shrihari Sankaran wrote:

Duh. If a module can't configure, it won't build, and if it won't build it won't install. If you don't get pygtk installed, guess what? "No module named gtk". Duh again.

So, what did they fail configure for?

I'm new to this Makefile and stuff. So, apologies for the noob questions.
I think I've worked out the problem here. There are three more instances of -export-symbols-regex that need to be changed to -export_symbol in pygtk-2.24.0/Makefile.

I tried to do this. But there was no Makefile. Only and I edited them and did "make && make install", but it aborted saying "missing separators". Same case inside pygtk-2.24.0/gtk also.

So, I tried to build the entire meta-gtk-osx-python again. Again, it failed on the modules 13, 14, 15, 16. The errors are here:

If there's no Makefile, edit and run configure to create Makefile. But the more immediate problem is that your whole python stack is failing configure (perhaps you forgot to rebuild Python?) You have to get that fixed before you can proceed.

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]