Re: [Gtk-osx-users] Issues with non-Latin keyboards

Op Di, 2010-05-04 om 06:45 -0700 skryf John Ralls:
> On May 4, 2010, at 4:35 AM, F Wolff wrote:
> > > 
> > > Ah, so you're using a normal Apple keyboard, and just changing the
> > > layouts in Language & Text / International, is that right? (Oh, I
> > > forgot to ask what version of OSX?)
> > > 
> > > Hmm. Looks like one needs to set $GTK_IM_MODULE somehow, but a
> > > cursory
> > > google doesn't show clearly to what it should be set. (This would
> > > be
> > > something handled in Linux by the Gnome desktop infrastructure
> > > which
> > > doesn't exist in Gtk-OSX, so we'll have to work out something
> > > else.)
> > > Do you know where the input modules live and how to set that
> > > variable?
> > 
> > Hi John
> > 
> > It seems I was a bit sparse in my description :-)  I'm on OSX 10.5
> > and
> > talking about a physical Apple keyboard with different layouts
> > selected
> > in System Preferences -> International -> Input Menu.
> > 
> > I think we tried the GTK IM as well (from the context menu) and it
> > didn't work correctly either. (In other words, at least some of them
> > seemed to have built correctly automatically.) We might have tried
> > Amharic which might not have had a font installed, so I'll need to
> > go
> > and confirm this again.  Of course, this shouldn't distract our
> > attention from the fact that plain keyboard layouts (with the
> > "simple"
> > IM) seems to not be working.
> > 
> Did you see my second rock about having to rebuild gtk+ with
> --with-included-immodules=yes?

Yes. I now reconfigured a whole build environment on my machine. Tested
things with and without --with-included-immodules=yes and I see no

However, I made some progress in my search for answers:

The keyboard layouts did work, but didn't display correctly. The default
font I had was monospace, and it didn't work. If I set it to Sans, the
Cyrillic input with the Mac's Russian layout worked (and was visible).

I tested now with the Thai keyboard layout, and it didn't work with
Sans, but if I select the Krungthep font (a system font that supports
Thai), it works.

So one of the issue seems to be that font fallback is not working.

Separately from that, I notice that:

 - GTK input methods (available from the context menu -> Input Methods)
seem to work. I had success with the Amharic and Cyrillic ones. (I
installed an extra font for Amharic.)

 - OSX input methods (not GTK input methods) don't work. I tried at
least two of the Chinese ones and the Hiragana one for Japanese. In some
cases plain ASCII text comes out, but in no case does even the pre-edit
appear as it does in TextEdit.

 - A custom keyboard for the Akan language that I have installed, can't
type the two characters for which it is needed (ɔ and ɛ) while the other
plain Latin characters that correspond to the US layout seems to be
working.  Such custom keyboard layouts are available here:

Any ideas for on these issues?


Recently on my blog:

Gtk-osx-users mailing list
Gtk-osx-users lists sourceforge net

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]