Re: libgtk-3-dev seems to break Ubuntu 12.04 LTS Unity Interface

I figured I'd follow-up on this in case someone else had the same problem.

I had been using aptitude (on Ubuntu 12.04) to install libgtk-3-dev. It asked me whether to accept a solution it offered regarding missing dependencies. I was answering "Y". The problem is that solution meant removing the ubuntu-desktop amongst many other things. The correct action would've been for me to say 'n' and then wait for aptitude to offer another solution which upgraded what needed to be upgraded without removing anything. Strangely, apt-get offers the correct solution first. The second solution aptitude offered was the correct one.

It might have been wise for me to do an "sudo aptitude upgrade" before installing libgtk.

Anyway, as one guy pointed out to me, ultimately the user is responsible for replying with a "Y" to aptitude's solutions. From now on, I will look very carefully at solutions aptitude offers.


From: David Buchan <pdbuchan yahoo com>
To: gtk-list list <gtk-list gnome org>
Sent: Friday, June 29, 2012 9:08 AM
Subject: libgtk-3-dev seems to break Ubuntu 12.04 LTS Unity Interface


I've been using Ubuntu 10.04 and libgtk2.0-dev and glade for a long time and recently attempted to bring myself into the present by doing a fresh install of 12.04 LTS.

But once I installed libgtk-3-dev and glade from the repository, I wasn't able to log back into the computer unless I typed cntl-alt-F1 and went to TTY. The graphical login screen accepts my credentials but then the screen very briefly shows a broken pipe message at the top-left of a TTY screen and then the login screen re-appears.

Scouring the web shows that many people have similar problems, but that there are many possible causes. I tried a number of solutions and one that allows me to get past the login while still in a graphical session, is to first go to TTY and sudo aptitude install gnome-panel. The problem with this solution is that Unity isn't rendered properly and is really unusable.

I *think* I saw that when I installed libgtk-3-dev, all kinds of gnome stuff is removed. Anway, it was either libgtk-3-dev or glade, because that's all I installed after the OS was installed.

I had tried going to a newer Ubuntu last year with the same results (maybe different cause?), so I stayed with 10.04. What's really extraordinary, is that last night I re-installed 10.04 when 12.04 failed as described above, and now 10.04 has the same problem (but with libgtk2.0-dev and glade)! Could it be that those libgtk packages have recently been changed and broke the Ubuntu interface? Seems unlikely.

Has anybody got suggestions and how to approach this? I saw some people talking about lightdm versus gdm. I also tried that (uninstall lightdm, install gdm), but *if* I recall (it was a late late night) although I got past login, Unity was all buggered with that too.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]