Re: Install problem on 2.4.0 - missing fontconfig

Hello Dave!

Yes fontconfig and freetype come with XFree86 4.4.0. I just did a tar ball of /usr/X11R6 as backup. The installation tool that comes with 4.4.0 seems to pretty robust and first checks if you have all necessary packages downloaded.

Another thing I had to do after installing pango was that the pkgconfig file for pangoxft was missing a -L/usr/X11R6/lib -lfontconfig. Did that happen to others, too? Without it, linking fails and the configure script for gtk-2.4.0 bails out with an error that it needs pango installed. On my system, X11R6 resides in /usr, and all other packages are under /usr/local. I setup the PKG_CONFIG_PATH such that pkg-config looks into both directories, i.e. pkg-config --list-all prints the packages under both directories. Is this an installation bug in pango?

Kind regards,


Dave Smith wrote:

Hi Steffen,

My system doesn't have any version of fontconfig installed. Is a fontconfig binary included as part of XFree86 4.4.0? Do you happen to have a list of all of the directories and files that need to be backed up and reinstalled on the updated system (in addition to XF86Config and xinitrc)?

Best regards,

On Wednesday 17 March 2004 20:35, Steffen Gutmann wrote:

I had the very same problem when installing gtk-2.3.4.

Most probably your fontconfig is too old.  I solved the problem by
installing latest XFree86 package 4.4.0.  You can find binaries for your
architecture on and the installation on my
system (RedHat 7.1) went smooth (but remember to do backups first,
especially xinitrc and XF68Config  I had to backup to get back to my
gnome desktop).

Kind regards,


Dave Smith wrote:

I had gtk+-2.2.4 installed and working on SuSE 8.1.  When upgrading to
gtk+-2.4.0, glib, pango, and atk all installed OK, but the configure
failed on gtk because the "pangoxft" package was not found.  The pango
configure complained that "fontconfig" was not found, but this same
message also appeared when building 2.2.4 (which built and ran OK).  I
assume that the changes in the gtk configure script were necessary to
support new features.

I tried to install "fontconfig", but I get a compilation error that:
`PS_FontInfoRec' is undeclared.  I found some communications in the
fontconfig archives stating that there may be a conflict with the version
of FreeType, but there was nothing that really gave a solution.

Has anyone else had this problem?  If so, what was your solution?

Thanks in advance,

Dave Smith

gtk-list mailing list
gtk-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]