Re: Install problem on 2.4.0 - missing fontconfig


I had the very same problem when installing gtk-2.3.4.

Most probably your fontconfig is tool old. I solved the problem by installing latest XFree86 package 4.4.0. You can find binaries for your architecture on and the installation on my system (RedHat 7.1) went smooth (but remember to do backups first, especially xinitrc and XF68Config I had to backup to get back to my gnome desktop).

Kind regards,


Dave Smith wrote:


I had gtk+-2.2.4 installed and working on SuSE 8.1. When upgrading to gtk+-2.4.0, glib, pango, and atk all installed OK, but the configure failed on gtk because the "pangoxft" package was not found. The pango configure complained that "fontconfig" was not found, but this same message also appeared when building 2.2.4 (which built and ran OK). I assume that the changes in the gtk configure script were necessary to support new features.

I tried to install "fontconfig", but I get a compilation error that:
`PS_FontInfoRec' is undeclared. I found some communications in the fontconfig archives stating that there may be a conflict with the version of FreeType, but there was nothing that really gave a solution.

Has anyone else had this problem?  If so, what was your solution?

Thanks in advance,

Dave Smith
gtk-list mailing list
gtk-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]