Re: Install problem on 2.4.0 - missing fontconfig

Hi Steffen,

After some work, I found:

* XFree86 4.4.0 does not include fontconfig.
* GTK+-2.4.0 still would not load (no fontconfig).
* 4.4.0 obsoleted my hand edited "/etc/X11/XF86Config" file (dual screens, 
keyboards, mice, etc.) and it would take some time to figure out how to 
create a proper working version in the 4.4.0 format.
* 4.4.0 also modified such things as the startup procedure, the printer setup, 
various preferences, etc.
* Thank goodness for the recommended backup procedures in the 4.4.0 
documentation so that the original setup could be restored quickly.
* I was subsequently able to load fontconfig 2.2.2 on the original setup after 
first loading freetype 2.1.4 (2.2.2 is apparently sensitive to the freetype 
version - not too old and not too new).  This fixed the missing fontconfig 
problem in the pango configuration script, but it then complained that it 
couldn't find Xft.
* Xft doesn't seem to be available by itself.

Given that others have a similar problem with a missing Xft system 
I have decided to stick with 2.2.4 until I have time to upgrade Linux to a 
newer distribution that includes the required files - if the system's basic 
setup/configuration needs to be redefined anyway, why not upgrade everything 
at the same time?  Does anyone know which Linux distributions will load 2.4.0 
starting from a clean installation?

Best regards,


On Thursday 18 March 2004 21:17, Steffen Gutmann wrote:
> Hello Dave!
> Yes fontconfig and freetype come with XFree86 4.4.0.  I just did a tar
> ball of /usr/X11R6 as backup.  The installation tool that comes with
> 4.4.0 seems to pretty robust and first checks if you have all necessary
> packages downloaded.
> Another thing I had to do after installing pango was that the pkgconfig
> file for pangoxft was missing a -L/usr/X11R6/lib -lfontconfig.  Did that
> happen to others, too?  Without it, linking fails and the configure
> script for gtk-2.4.0 bails out with an error that it needs pango
> installed.  On my system, X11R6 resides in /usr, and all other packages
> are under /usr/local.  I setup the PKG_CONFIG_PATH such that pkg-config
> looks into both directories, i.e. pkg-config --list-all prints the
> packages under both directories.  Is this an installation bug in pango?
> Kind regards,
>     Steffen
> Dave Smith wrote:
> >Hi Steffen,
> >
> >My system doesn't have any version of fontconfig installed.  Is a
> > fontconfig binary included as part of XFree86 4.4.0?  Do you happen to
> > have a list of all of the directories and files that need to be backed up
> > and reinstalled on the updated system (in addition to XF86Config  and
> > xinitrc)?
> >
> >Best regards,
> >
> >Dave
> >
> >On Wednesday 17 March 2004 20:35, Steffen Gutmann wrote:
> >>Hi,
> >>
> >>I had the very same problem when installing gtk-2.3.4.
> >>
> >>Most probably your fontconfig is too old.  I solved the problem by
> >>installing latest XFree86 package 4.4.0.  You can find binaries for your
> >>architecture on and the installation on my
> >>system (RedHat 7.1) went smooth (but remember to do backups first,
> >>especially xinitrc and XF68Config  I had to backup to get back to my
> >>gnome desktop).
> >>
> >>Kind regards,
> >>
> >>    Steffen
> >>
> >>Dave Smith wrote:
> >>>Hi,
> >>>
> >>>I had gtk+-2.2.4 installed and working on SuSE 8.1.  When upgrading to
> >>>gtk+-2.4.0, glib, pango, and atk all installed OK, but the configure
> >>>failed on gtk because the "pangoxft" package was not found.  The pango
> >>>configure complained that "fontconfig" was not found, but this same
> >>>message also appeared when building 2.2.4 (which built and ran OK).  I
> >>>assume that the changes in the gtk configure script were necessary to
> >>>support new features.
> >>>
> >>>I tried to install "fontconfig", but I get a compilation error that:
> >>>`PS_FontInfoRec' is undeclared.  I found some communications in the
> >>>fontconfig archives stating that there may be a conflict with the
> >>> version of FreeType, but there was nothing that really gave a solution.
> >>>
> >>>Has anyone else had this problem?  If so, what was your solution?
> >>>
> >>>Thanks in advance,
> >>>
> >>>Dave Smith
> >
> >_______________________________________________
> >gtk-list mailing list
> >gtk-list gnome org
> >

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]