Re: ANNOUNCE: gtkentrymask - gtkentry with masks and types

Following the suggestions of Havoc, I have renamed the project gtkentrymask
to gtkwidgexts. You can find it now at:

I have changed the namespace to gtkx, so the GtkEntryMask widget is now
named GtkxEntryMask, and so the rest of widgets, filenames, etc.

Merry Christmas,

Havoc Pennington escribió:

> Santiago Capel <bluefish ono com> writes:
> > Hello, I am proud to announce a new gtk entry widget that allows to add
> > type and mask (with internationalization, I hope ;-) ) to gtkentry. It
> > is at:
> >
> >
> This looks like a useful widget, it may even work in to the validation
> feature for GtkEntry. See
>  We also need to
> research APIs for this in Java/Swing, Qt, and System.WinForms from the
> .NET platform to see what ideas can be gathered.
> > This is one of the several extended widgets that I plan to make. The
> > package is called gtkwidgexts.
> It's important to use your own namespace for your package, rather than
> the GTK namespace. i.e. call the widgets FooEntryMask,
> foo_entry_mask_new(), etc. - obviously replace "foo" with a better name.
> Using GTK's namespace causes problems with symbol collisions.
> Havoc

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]