Re: [gtk-list] Re: Perl/Gtk CVS 19990922

Paolo Molaro wrote:
> This program doesn't core here:
> gnome-libs 1.0.10
> gtk+ 1.2.4
> imlib 1.9.7
> Maybe the problem is imlib, as Elliot suggests?
I was never really sure about my imlib :-) I have rebuilt imlib from
the CVS version 1.9.7, rebuilt gtk+, rebuilt gnome-libs-1.0.16, rebuilt
gnome-perl (from CVS yesterday) and rebuilt glade (from CVS yesterday) but
the little script (and my big one that uses Gnome::Pixmap) still dumps core. 

The only other light than I can shed is that in the gnome-perl 'make test'
I particlarly tried the Gdk stuff and got hundreds of messages like:
    Gdk-WARNING **: losing last reference to undestroyed window
from the GdkImlib test as it exited.

Also the RawGdk test just showed a black square and refused to go away, 
even after I had quit the test UI, until I kill()ed the perl process that 
was left running, no core dumps though.

Everything else seems fine, Glade runs and other Gtk apps seem happy.

> You may try to run the script with gdb to what's going on.
I have never used gdb (successfully). How do I use it to debug such a 
script? You mentioned 'perldebug' ages ago but I never worked out what 
you meant.

> lupus
> PS Always "use Gnome" if you use gnome features: in the near future
> the gnome support will be compiled in a package of his own.
Noted, thank you.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]