Re: Chinese XIM and GTK+ 2

I cannot do exactly the same with chinese locales and a chinput, But,

LANG=en_US.UTF-8 LC_CTYPE=ja_JP.UTF-8 gedit

seems to work in japanese locale and with a kinput2.

Do you see a warning message like:
 (gedit:11891): Gtk-WARNING **: Loading IM context type 'xim' failed
If you don't see this, then try with "GTK_IM_MODULE=xim".


Stefan Baums wrote:

Dear list,

the problem du jour is: When running a GTK+ 2 application (I tried
gedit and gimp) under


I am not able to enter Chinese characters via an XIM program
(chinput, but I also tried others).  Why do I have different
settings for LANG and LC_CTYPE?  Well, ideally I would like both
to be en_US.UTF-8, but chinput refuses to serve characters to
applications that do not run under a Chinese (zh_X.Y) locale.  Why
don't I set everything to zh_TW.UTF-8?  Because I don't want menus
etc. to be in Chinese (just beginning to learn the language).
When I do experimentally run e.g.

  LANG=zh_TW.UTF-8 LC_CTYPE=zh_TW.UTF gedit

everything (almost, see other email) works.  This looks like
something that GTK+ 2 is getting wrong.  Does anybody know how to
fix it?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]