Re: a new combo box



On Mon, Dec 29, 2014 at 1:53 AM, Matthias Clasen <matthias clasen gmail com> wrote:
I am a bit disappointed by the turn this discussion has taken - I was
hoping people would try the code I pointed to and let me know what
they think and point out problems (thanks to Tim for doing just that).

Some other comments in addition to what Timm and Emmanuele already said:
- gtk_combo_remove_item() and gtk_combo_set_active() should probably return a gboolean for the case the ID is not found. Alternatively (or in addition to that), a gtk_combo_has_item() API could probably be added too
- what is the purpose of the "inverted" property of GtkComboRow? It doesn't seem to be used in the class as far as I can see
- it would be nice to share the key press event code with the one in GtkSearchEntry instead of duplicating it
- how does gtk_combo_add_group() behave when called on a group ID that already exists? I assume it just sets the new value on the existing group properties, but then the method name is a bit misleading
- consider adding a gtk_combo_remove_group() that takes a group ID

Finally, I think the widget exacerbates one of the problems with GtkPopovers - the fact that they can't draw outside of the parent window. In testnewcombo this is visible in the "With Gropuping" example when "G 3" is selected; the "show more" button is drawn half cut with the default window size on my laptop.

Cosimo


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]