Re: glib-mkenums in glib 2

At 27.12.2012 11:56, John Emmas wrote:

Knowing that I'd at least managed to get _something_ working, I then tried
running 'glib-mkenums' again - this time using Perl from MinGW/MSYS.
However, that essentially gave me the same error that I reported in the
first place:-

/* Generated data (by glib-mkenums) */

Use of uninitialized value in substitution (s///) at
/usr/lib/perl5/5.8.8/File/ line 338.
fileparse(): need a valid pathname at glib-mkenums line 259

I suppose I could try installing Strawberry Perl but wherever the fault
lies, it's looking as if glib-mkenums can't be made to work successfully on
Windows (at least, probably not without installing Cygwin).

Has anyone managed to run that script successfully for a plain MSVC (or
MinGW) build?

Yes, for years. The error you are refering to is missing filenames AFAICT.
You have to pass the headers to generate enums from as parameters to glib-mkenums like done in gio/makefile.msc

-------- Hans "at" Breuer "dot" Org -----------
Tell me what you need, and I'll tell you how to
get along without it.                -- Dilbert

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]